Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night my laptop froze up and I had to do a hard shutdown. Now Xubuntu won't boot up. I was getting the error message "mountall: error while loading shared libraries: libply-boot-client.so.2: cannot open shared object file: Input/output error". I tried 'Advanced options for Ubuntu> recovery mode' and selected fsck but received the same error.

I searched for an answer with no success. An old post suggested using a live boot to mount and chroot the partition and update mountall but that didn't work. I now get a blinking cursor when trying to do a normal boot.

I even tried to reinstall plymouth but received a message about breaking it. I was getting the error "plymouth: error while loading shared libraries: libply.so.2: cannot open shared object files: Input/output error" beforehand but that stopped.

Please help.

share|improve this question
add comment

1 Answer

That sounds to me like a disk drive problem. You can boot from a live CD and use smartctl to confirm.

share|improve this answer
    
@ James Fu I used 'sudo smartctl -Hc /dev/sda' and it's said "SMART overall-health self-assessment test result: PASSED". –  P J Oct 24 '13 at 3:08
    
@PJ That's good news. After chroot-ing, can you try sudo apt-get install --reinstall libplymouth2 and report back? –  James Fu Oct 24 '13 at 13:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.