Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last night my laptop froze up and I had to do a hard shutdown. Now Xubuntu won't boot up. I was getting the error message "mountall: error while loading shared libraries: cannot open shared object file: Input/output error". I tried 'Advanced options for Ubuntu> recovery mode' and selected fsck but received the same error.

I searched for an answer with no success. An old post suggested using a live boot to mount and chroot the partition and update mountall but that didn't work. I now get a blinking cursor when trying to do a normal boot.

I even tried to reinstall plymouth but received a message about breaking it. I was getting the error "plymouth: error while loading shared libraries: cannot open shared object files: Input/output error" beforehand but that stopped.

Please help.

share|improve this question

That sounds to me like a disk drive problem. You can boot from a live CD and use smartctl to confirm.

share|improve this answer
@ James Fu I used 'sudo smartctl -Hc /dev/sda' and it's said "SMART overall-health self-assessment test result: PASSED". – P J Oct 24 '13 at 3:08
@PJ That's good news. After chroot-ing, can you try sudo apt-get install --reinstall libplymouth2 and report back? – James Fu Oct 24 '13 at 13:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.