Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have setup a MAAS environment and using Juju to deploy services. I followed the simple juju tutorial of trying to deploy Mysql and Wordpress. The bootstrap node has come up fine without any errors. However, on deploying Mysql (juju deploy --repository=<path> local:raring/mysql (got the mysql and wordpress charms using bzr)), the maas node did the ubuntu installation over the network using PXE boot (all of that seems to be working correctly).

However, the charm doesn't seem to come-up. Juju status is stuck in pending state and the logs (of the machine-1, which is to deploy the charm) seem to suggest that the exec of the start --system jujud-unit-mysql-0 has failed due to unable to connect to the sytem bus (/var/run/dbus/system_bus_socket).

There are other posts on this forum indicating that this may be caused by issues with /var/run and /run (but that might have been fixed in raring series), and also possibly use of sudo command may be needed.

Obviously this is something that is being spawned off from within Juju and I have no control (to use sudo or not to execute that command to deploy the charm). Can someone please help in debugging this issue. Thanks in advance.

juju status

environment: maas
machines:
  "0":
    agent-state: started
    agent-version: 1.16.0
    dns-name: Honeybee-2.MaasCluster
    instance-id: /MAAS/api/1.0/nodes/node-0abcb8ec-378b-11e3-b1d0-00155d964216/
    series: raring
  "1":
    agent-state: started
    agent-version: 1.16.0
    dns-name: Honeybee-3.MaasCluster
    instance-id: /MAAS/api/1.0/nodes/node-58eddf9c-379e-11e3-b1d0-00155d964216/
    series: raring
services:
  mysql:
    charm: local:raring/mysql-309
    exposed: false
    relations:
      cluster:
      - mysql
    units:
      mysql/0:
        agent-state: pending
        machine: "1"
        public-address: Honeybee-3.MaasCluster

#ssh ubuntu@Honeybee-3.MaasCluster
# less /var/log/juju/machine-1.log 

2013-10-23 20:32:05 INFO juju.worker.deployer deployer.go:146 deploying unit "mysql/0"
2013-10-23 20:32:05 INFO juju.worker.machiner machiner.go:52 "machine-1" started
2013-10-23 20:32:05 INFO juju.worker.upgrader upgrader.go:134 desired tool version: 1.16.0
2013-10-23 20:32:05 DEBUG juju.worker.deployer simple.go:91 state addresses: ["Honeybee-2.MaasCluster:37017"]
2013-10-23 20:32:05 DEBUG juju.worker.deployer simple.go:96 API addresses: ["Honeybee-2.MaasCluster:17070"]
2013-10-23 20:32:06 WARNING juju.worker.deployer simple.go:244 installer: cannot remove "/var/lib/juju/agents/unit-mysql-0": remove /var/lib/juju/agents/unit-mysql-0: directory not empty
2013-10-23 20:32:06 ERROR juju runner.go:211 worker: exited "deployer": exec ["start" "--system" "jujud-unit-mysql-0"]: exit status 1 (start: Unable to connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)
2013-10-23 20:32:06 INFO juju runner.go:245 worker: restarting "deployer" in 3s
2013-10-23 20:32:09 INFO juju runner.go:253 worker: start "deployer"
2013-10-23 20:32:09 INFO juju.worker.deployer deployer.go:106 checking unit "mysql/0"
2013-10-23 20:32:09 INFO juju.worker.deployer deployer.go:106 checking unit "mysql/0"
(END)


#dpkg -l dbus
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  dbus           1.6.8-1ubunt amd64        simple interprocess messaging sys
share|improve this question

1 Answer 1

In order to add more informations on this issue : I'm also encoutering the same behaviour when deploying "juju-gui" charm on a Saucy Salamander based MAAS node.

I also got this charm through bzr (with charm get juju-gui).

I'm noting that we have the same problem with different charms, Ubuntu serie and even Juju version.

My juju status :

services:
  juju-gui:
    charm: local:saucy/juju-gui-99
    exposed: false
    units:
      juju-gui/0:
        agent-state: pending
        machine: "1"
        public-address: node2.opc-ss.com

Logs on the node :

2013-11-19 08:51:08 INFO juju.worker.deployer deployer.go:146 deploying unit "juju-gui/0"
2013-11-19 08:51:08 INFO juju.worker.upgrader upgrader.go:134 desired tool version: 1.16.3
2013-11-19 08:51:08 INFO juju.worker.machiner machiner.go:52 "machine-1" started
2013-11-19 08:51:09 WARNING juju.worker.deployer simple.go:244 installer: cannot remove "/var/lib/juju/agents/unit-juju-gui-0": remove /var/lib/juju/agents/unit-juju-gui-0: directory not empty
2013-11-19 08:51:09 ERROR juju runner.go:211 worker: exited "deployer": exec ["start" "--system" "jujud-unit-juju-gui-0"]: exit status 1 (start: Unable to connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)
2013-11-19 08:51:09 INFO juju runner.go:245 worker: restarting "deployer" in 3s
2013-11-19 08:51:09 INFO juju.provisioner provisioner_task.go:102 Starting up provisioner task machine-1
2013-11-19 08:51:12 INFO juju runner.go:253 worker: start "deployer"
2013-11-19 08:51:12 INFO juju.worker.deployer deployer.go:106 checking unit "juju-gui/0"
2013-11-19 08:51:12 INFO juju.worker.deployer deployer.go:106 checking unit "juju-gui/0"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.