Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the hard drive from a PowerMac G5, which was my old computer before it died and I upgraded to Ubuntu Studio.

The hard drive its self still works well, but on Ubuntu I can't access most of the files. I plugged it into my MacBook Air and changed some of the perms on some of the folders as a test. This worked for a few, but for others, I was getting the same message

Cannot access folder.  Access denied.

I would like to use this as an external HDD (I have a case and everything), but it's kind of pointless if I can't access the folders that I want. After looking around for a couple of hours, I couldn't find anything that actually gave me an answer.

I would like to know if:

  1. Anybody else has come upon this problem,
  2. If so, have you found a solution? and,
  3. What is it?
share|improve this question
    
Have you tried accessing it as root? If it is just a permissions problem, this may work. If it is encrypted, only a few partitions of it may be encrypted - this could be verified using a program such as GParted or fdisk. –  Wilf Oct 23 '13 at 22:16
    
I will try this, but I believe that the problem is coming from a miscommunication between Apple and Ubuntu. –  soundblastdj Oct 23 '13 at 22:25
    
Nope, that didn't work, though I learned a bit about using the sudo command and the other things that it can do –  soundblastdj Oct 23 '13 at 22:34
    
I find that most permissions can be got around by using root on nearly any Linux system. I still suggest trying gparted - the command for installing should be sudo apt-get install gparted. Then look at this - which will show whether your computer is missing any packages to interpret different disk formatting types. You should be able to find the disk formatting, which may not be read or write to it well with Linux, as it is designed only for use with the Mac operating system. –  Wilf Oct 23 '13 at 22:46
    
I was able to do most of the actions listed in gparted after I installed the plugins, but this did not fix my problem. –  soundblastdj Oct 23 '13 at 23:00

2 Answers 2

up vote 1 down vote accepted

I figured it out!!!!

I used Midnight Commander go in as root and I copied all of the files to a new HDD, telling it to ignore all of the tags. I now have access to all of my music.

The problem, as it turns out, is that the disk is mounted as read-only. I would love to figure out why, but I'm happy with the way it is right now.

Thank you to all who helped.

share|improve this answer

As if from a Mac, it is likely to be formatted as hfsplus, which is a filesystem type used by Apple. This can have varying compatibility with Linux.

If it does not automount, try mount -t hfsplus /dev/sdX0 /EMPTY-DIRECTORY-WHERE-YOU-WANT-TO-MOUNT-IT in terminal. It may come up as read-only though. /dev/sdX0 is the name of your hfs+ drive, and the partition which you need to mount.

When it has mounted run sudo nautilus /PATH/TO/WHERE/THE/DISK/HAS/MOUNTED/ and you should be able to read and write to it, so you can copy stuff off. After you have copied the files though, you will need to modify the permissions of the copied files to access it with your normal user. You could do this is by using the file manager as root, by right-clicking and and then clicking Properties and then Permissions, or by using chmod.

After you have copied the files you want, AND ARE SURE THAT ALL OF YOUR IMPORTANT DATA IS OFF THE DISK, you can then format it using GParted to a file-system like ext or FAT, and use it as a external hard disk.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.