Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install 12.04, 13.04, and now 13.10 on the machine and followed all the instructions that made sense that I could find and still have not gotten wifi to work.

It keeps it hard blocked for some reason, not sure why and not sure anyone out there either has figured it out because I would have found it on Google.

  • When I boot from the formatted USB drive, I have WiFi and everything working, why doesn't work after the USB drive is removed?

  • What driver is the USB/wubi or whatever using so that I can install it and have things working? I could have used wubi and installed Ubuntu like that, but I want to make this machine a fully dedicated Ubuntu machine.

  • The laptop is a Lenovo S205 in case anyone can help. I really would like to use 12.04 or higher, i don't want to downgrade to an older version of Ubuntu if at all possible.

share|improve this question
    
That might be a general thinkpad issue. Retagging your post. This has happened to me on my Thinkpad X60 Tablet, but it was solved by a good old reboot. –  Yet Another User Oct 23 '13 at 21:19
2  
As with any OS, if you purchase compatible hardware, it works. You can buy USB wireless cards compatible with Linux/Ubuntu for about $10. –  bodhi.zazen Oct 23 '13 at 21:24
    
This question doesn't have much information about your hardware we need, can you look at this question and add some hardware info? askubuntu.com/questions/14008/… –  Jorge Castro Oct 23 '13 at 21:35
    
Specifically we need the model of your wireless card, so if you can boot into Windows to get that then that's fine too. –  Jorge Castro Oct 23 '13 at 21:38
    
I thought I replied to this already, maybe it didn't accept the submission. Here it is, RT3090 Ralink. I followed the link on the Lenovo site and looks like Ralink merged with MediaTek. I downloaded the driver that was supposed to be the RT3090 but it turned it wasn't it. –  user206829 Oct 23 '13 at 23:09
show 1 more comment

2 Answers 2

Do you know what wireless device you are using? - run lspci (or lsusb) in terminal or something to find out.

Some drivers that are automatically installed don't work very well - check the driver here. (you should be able to find it in the lspci (or lsusb) output - run it with the -vvv option (lspci -vvv) against the device.

For instance my lspci output for my wireless is:

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01) ...

...Kernel driver in use: bcma-pci-bridge

Also, have a look at programs like rfkill, which can be used to block and unblock wifi. Also, some Lenovo models have a switch to turn on and off the wifi. This is a low-profile switch and is probably located near the front. Mine (for a different Lenovo model) is located underneath front near the touchpad.

Also look at this: http://ubuntuforums.org/showthread.php?t=1850027

share|improve this answer
    
Please don't add comments as answers. Use actual comments when seeking clarification of any issues. –  Braiam Oct 23 '13 at 21:30
    
I cannot comment any way @Braiam. Found bugs with Ubuntu with that laptop model at: bugs.launchpad.net/ubuntu/+source/linux/+bug/1019663 –  Wilf Oct 23 '13 at 21:40
    
You have +50 rep, of course you can ;). –  Braiam Oct 23 '13 at 21:47
    
rfkill unblock all / list all still shows the Wireless LAN Hard Blocked: yes –  user206829 Oct 23 '13 at 22:35
    
Just checked on my Lenovo, rfkill with the hardware switch off (so that the wireless is off) shows as hard blocked - I would definitely look for a hardware switch - try to the right of the audio ports. –  Wilf Oct 24 '13 at 8:46
add comment

WiFi is anything but simple. Important, yes, but not simple.

The S205 could have many different PCI Express WiFi minicards... some which may not have Linux drivers, as confirmed by this post http://forums.lenovo.com/t5/IdeaPad-S-series-Netbooks/WIFI-connection-not-found-on-new-s205/td-p/532659 .

The S205 is consumer, not professional, equipment, after all, and there's historically more trouble with consumer gear. I had the same problem with my SL400 Thinkpad (also consumer, since replaced with business grade gear) so replaced the card with one known to work well with Ubuntu; problem solved.

You might wish to review the hardware manual at http://download.lenovo.com/UserFiles/UserGuide/en/User's%20guides%20and%20manuals/S205/Lenovo%20IdeaPad%20S205%20Hardware%20Maintenance%20Manual.pdf which shows how to replace the card.

However, here's a thread showing where to find drivers for the RAlink WiFi card you might have: http://forums.lenovo.com/t5/IdeaPad-S-series-Netbooks/Ideapad-S205-Wireless-N/td-p/453153

share|improve this answer
    
I just bought this from amazon: amazon.com/Panda-150Mbps-Wireless-N-2-4GHz-Adapter/… –  user206829 Oct 23 '13 at 23:57
    
I hit the enter too soon, I seen some reviews that it works with 13.04 and it had a lot of great reviews. It's small enough to be out of the way and not have to worry about. –  user206829 Oct 23 '13 at 23:58
    
Good for you! USB wifi usually works OK. Here is kiloseven's link again: S205 Manual –  Wilf Oct 24 '13 at 8:37
    
Also, found that the manual says that (on page 61), that the hardware switch is next to the audio ports. I also found that installing with this set to on ended with the best results. Just shows is this picture to the right of the audio ports - but this may be a different model. I spent 3 months looking to sort the wireless on my Lenovo, and eventually discovered that it was the hardware switch. –  Wilf Oct 24 '13 at 8:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.