Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Issue

I'd like to install the XFCE interface alongside the GNOME interface that comes preinstalled with Ubuntu.

However, when I try to install the package xubuntu-desktop, I end up with this:

[kahless]# aptitude install xubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Writing extended state information... Done
The following packages are BROKEN:
  ubuntu-desktop 
The following NEW packages will be installed:
  a2ps{a} abiword abiword-common{a} abiword-plugin-grammar{a} 
  abiword-plugin-mathview{a} app-install-data-commercial aumix{a} 
  aumix-common{a} catfish exaile exo-utils{a} fortune-mod{a} 
  fortunes-min{a} gigolo gnumeric gnumeric-common{a} gnumeric-doc{a} 
  gtk2-engines-xfce libabiword-2.8{a} libaiksaurus-1.2-0c2a{a} 
  libaiksaurus-1.2-data{a} libaiksaurusgtk-1.2-0c2a{a} libexo-0.3-0{a} 
  libexo-common{a} libgdome2-0{a} libgdome2-cpp-smart0c2a{a} 
  libgtkmathview0c2a{a} liblink-grammar4{a} libotr2{a} libots0{a} 
  libpsiconv6{a} librecode0{a} libscim8c2a{a} libsdl1.2debian-alsa 
  libtagc0{a} libthunar-vfs-1-2{a} libwv-1.2-3{a} libxfce4menu-0.1-0{a} 
  libxfce4util-bin{a} libxfce4util-common{a} libxfce4util4{a} 
  libxfcegui4-4{a} libxfconf-0-2{a} libxmlrpc-core-c3{a} 
  link-grammar-dictionaries-en{a} mousepad murrine-themes{a} orage 
  oss-compat{a} pidgin pidgin-data{a} pidgin-libnotify{a} pidgin-otr 
  psutils{a} python-cddb{a} python-mmkeys{a} python-mutagen{a} 
  python-sexy{a} ristretto scim scim-bridge-agent{a} 
  scim-bridge-client-gtk{a} scim-gtk2-immodule{a} scim-modules-socket{a} 
  scim-modules-table{a} scim-tables-additional tango-icon-theme-common 
  thunar thunar-archive-plugin thunar-data{a} thunar-media-tags-plugin 
  thunar-thumbnailers thunar-volman{a} thunderbird ttf-lyx{a} usb-creator 
  xfce-keyboard-shortcuts{a} xfce4-appfinder xfce4-clipman{a} 
  xfce4-clipman-plugin xfce4-cpugraph-plugin xfce4-dict 
  xfce4-fsguard-plugin xfce4-mailwatch-plugin xfce4-mixer 
  xfce4-mount-plugin xfce4-netload-plugin xfce4-notes{a} xfce4-notes-plugin 
  xfce4-panel{a} xfce4-places-plugin xfce4-power-manager 
  xfce4-power-manager-data{a} xfce4-quicklauncher-plugin 
  xfce4-screenshooter xfce4-session xfce4-settings{a} 
  xfce4-smartbookmark-plugin xfce4-systemload-plugin xfce4-terminal 
  xfce4-utils{a} xfce4-verve-plugin xfce4-volumed xfce4-weather-plugin 
  xfce4-xkb-plugin xfconf{a} xfdesktop4{a} xfdesktop4-data{a} xfprint4 
  xfswitch-plugin xfwm4{a} xfwm4-themes{a} xscreensaver xubuntu-artwork{a} 
  xubuntu-default-settings xubuntu-desktop xubuntu-docs 
  xubuntu-gdm-theme{a} xubuntu-icon-theme{a} xubuntu-plymouth-theme{a} 
  xubuntu-wallpapers{a} 
The following packages will be REMOVED:
  libsdl1.2debian-pulseaudio{a} xaw3dg{u} 
0 packages upgraded, 121 newly installed, 2 to remove and 1 not upgraded.
Need to get 75.7MB of archives. After unpacking 261MB will be used.
The following packages have unmet dependencies:
  ubuntu-desktop: Depends: libsdl1.2debian-pulseaudio but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
ubuntu-desktop

Leave the following dependencies unresolved:
catfish recommends slocate
Score is -81

Accept this solution? [Y/n/q/?]

These lines here worry me the most:

Remove the following packages:
ubuntu-desktop

Is there a way to install the XFCE desktop alongside Gnome without causing ubuntu-desktop to break?

More Info (1)

Using apt-get results in the same issue.

More Info (2)

Attached are the other solutions that aptitude provides:

Solution 1 was listed above.

Solution 2: The following actions will resolve these dependencies:

Keep the following packages at their current version:
libsdl1.2debian-alsa [Not Installed]
libsdl1.2debian-pulseaudio [1.2.14-4ubuntu1.1 (lucid-updates, now)]

Leave the following dependencies unresolved:
catfish recommends slocate
xubuntu-desktop recommends libsdl1.2debian-alsa
Score is -210

Accept this solution? [Y/n/q/?] 

Solution 3:

The following actions will resolve these dependencies:

Keep the following packages at their current version:
libsdl1.2debian-alsa [Not Installed]

Downgrade the following packages:
libsdl1.2debian [1.2.14-4ubuntu1.1 (lucid-updates, now) -> 1.2.14-4ubuntu1 (lucid)]
libsdl1.2debian-pulseaudio [1.2.14-4ubuntu1.1 (lucid-updates, now) -> 1.2.14-4ubuntu1 (lucid)]

Leave the following dependencies unresolved:
catfish recommends slocate
xubuntu-desktop recommends libsdl1.2debian-alsa
Score is -220

Accept this solution? [Y/n/q/?] 
share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I think aptitude is trying to remove ubuntu-desktop because it is broken:

"The following packages are BROKEN:
ubuntu-desktop"   

1) You can go to System > Administration Synaptic Package Manager then go to Edit > Fix broken packages.

2) If "1" fails, then choose "n" to not accept the option of remove ubuntu-desktop.

3) To restore the Gnome login manager:

gksu gedit /etc/X11/default-display-manager  

and change it's content to /usr/sbin/gdm

ps.: if you don't like the gdm xubuntu theme, you can remove it:

sudo aptitude remove xubuntu-gdm-theme  

Regards.

share|improve this answer
    
@desgua: nope, doesn't work. I think its because of this: ubuntu-desktop: Depends: libsdl1.2debian-pulseaudio but it is not installable, and the system is trying to remove libsdl1.2debian-pulseaudio. Any other ideas? –  Thomas W. Apr 22 '11 at 18:19
    
I added the additional 2 solutions given by aptitude to the answer under More Info (2) –  Thomas W. Apr 22 '11 at 19:06
    
Option 2 looks like it will work. –  BillThor Apr 22 '11 at 19:39
    
I'm testing option 2 now, i hope everything doesn't implode :/ –  Thomas W. Apr 22 '11 at 20:19
    
Well, that option worked. @BillThor Last question, how can I restore the Gnome login manager? I like the GNOME login screen better than the XFCE one. –  Thomas W. Apr 22 '11 at 20:30
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.