Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded from 13.04 to 13.10 and now I'm having a problem with the nvidia X server settings: the changes I make don't stay saved after I restart the X server.

I checked the xorg.conf (/etc/X11/xorg.conf) and it's ok but I think it's not being used. Did they move the xorg.conf file?

share|improve this question
    
It could be that lightdm is overriding you setting. See this answer askubuntu.com/a/424533/248874 –  Cornelius Feb 22 at 9:53
    
sorry. deleted my comment. –  Cornelius Feb 22 at 10:40
add comment

4 Answers 4

The xserver.configfile for Ubuntu 13.10 is located at /etc/X11/xorg.conf . You can change the Nvidia settings by using the nvidia-settings application from the Ubuntu Software Center. nvidia-settings is a graphical application for changing the Nvidia settings. To launch nvidia-settings search for nvidia in the Dash and click on the green icon that says NVIDIA X Server Settings.

enter image description here

share|improve this answer
    
I'm having the same problem as seiki. @karel, saving to /etc/X11/xorg.conf doesn't solve it, because after reboot the wrong settings are applied again. So it looks they changed the location or xorg.conf –  netiul Oct 25 '13 at 7:04
1  
@netiul Two suggestions: 1) in the terminal type man xorg.conf and you'll find the path to xorg.conf in the top of the xorg.conf manual page under the DESCRIPTION heading. 2) Are you using the nano editor to edit your xorg.conf file? Using sudo gedit to edit a file that is owned by root can cause real problems with other graphical apps. –  karel Oct 25 '13 at 7:34
1  
I'm configuring xorg.conf using the NVIDIA X Server settings tool. I can see that /etc/X11/xorg.conf gets modified. Still the wrong settings are applied after reboot. –  netiul Oct 31 '13 at 7:48
    
I think this answer by Oli may help. Also read the question that the answer is for. Oli says if you've got both the Intel integrated graphics and the Nvidia discrete graphics, then you have to install the Bumblebee package first. –  karel Oct 31 '13 at 7:56
    
And btw, I've only one xorg.conf on my system and that's the one in /etc/X11/. I also deleted xorg.conf and created a new one with NVIDIA tool in case there was something wrong with file. Still no louck. Very strange! –  netiul Oct 31 '13 at 7:56
add comment

I don't own Nvidia cards/chips anymore, but I found the following things:

  • Arch Wiki recommends saving the contents of your customized Nvidia xorg.conf in /etc/X11/xorg.conf.d/20-nvidia.conf. That sounds logical as I can see some configuration files in /usr/share/X11/xorg.conf.d/ on my 13.10 installations.

  • In a post on the Majaro Linux forums (a Ubuntu derivative) a user says he had to save the contents to /etc/X11/mhwd.d/nvidia.conf. MHWD is the Manjaro Hardware Detection. Probably not a solution for Ubuntu, but it may give a hint.

  • Rather unlikely but may be saving the contents to /etc/X11/Xsession.d/20_custom_nvidia-config or referencing them in a simple script there might work. See the manpage for Xsession.

share|improve this answer
add comment

Here is the temporal solution. https://bbs.archlinux.org/viewtopic.php?pid=1299520#p1299520

The problem is in .nvidia-settings-rc file in your home folder. As the link above suggests, you should:

  1. Change the settings to your liking, using the GUI as usual. Quit the GUI application to save your changes.
  2. Edit the config file (~/.nvidia-settings-rc) in a text editor to remove every mention of your machine's hostname. (Leave everything else just as it is, only remove the actual letters of the hostname.); and
  3. Write-protect the config file when you're finished.
share|improve this answer
add comment

It could be that lightdm is overriding you setting. See this answer here:

http://askubuntu.com/a/424533/248874

share|improve this answer
add comment

protected by Community Feb 11 at 23:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.