Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Fujitsu Lifebook A-6120. After installing raring ringtail I have no sound. Not through the speakers or headphones. The built in microphone is working according to sound settings. Also in sound settings it does list a built in output device. Here's what I have tried so far:

  • My sound is not muted. I have checked the alsamixer to verify.
  • I have removed and reinstalled alsa and pulseaudio.
  • I have updated everything.
  • I have gone into the /etc/modprobe.d/alsa-base.conf file and added the following line to the end: options snd-hda-intel model=fujitsu. I have also tried model=base and model=generic.
  • My sound was working in Windows 7 before I installed 13.04, so it's not a hardware issue.

Every forum seems to think that modifying the /etc/modprobe.d/alsa-base.conf file will fix the issue, so I have posted the contents of the file down here. I really appreciate any help on this issue.

autoloader aliases

install sound-slot-0 /sbin/modprobe snd-card-0 install sound-slot-1 /sbin/modprobe snd-card-1 install sound-slot-2 /sbin/modprobe snd-card-2 install sound-slot-3 /sbin/modprobe snd-card-3 install sound-slot-4 /sbin/modprobe snd-card-4 install sound-slot-5 /sbin/modprobe snd-card-5 install sound-slot-6 /sbin/modprobe snd-card-6 install sound-slot-7 /sbin/modprobe snd-card-7

Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; } #

Workaround at bug #499695 (reverted in Ubuntu see LP #319505)

install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; } install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; } install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; } # install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }

Cause optional modules to be loaded above sound card driver modules

install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; } install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)

install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }

Prevent abnormal drivers from grabbing index 0

options bt87x index=-2 options cx88_alsa index=-2 options saa7134-alsa index=-2 options snd-atiixp-modem index=-2 options snd-intel8x0m index=-2 options snd-via82xx-modem index=-2 options snd-usb-audio index=-2 options snd-usb-caiaq index=-2 options snd-usb-ua101 index=-2 options snd-usb-us122l index=-2 options snd-usb-usx2y index=-2

Ubuntu #62691, enable MPU for snd-cmipci

options snd-cmipci mpu_port=0x330 fm_port=0x388

Keep snd-pcsp from being loaded as first soundcard

options snd-pcsp index=-2

Keep snd-usb-audio from beeing loaded as first soundcard

options snd-usb-audio index=-2 options snd-hda-intel model=fujitsu

share|improve this question

1 Answer 1

Did you install 'third part software' during the install? Check if you have this packages installed: gstreamer0.10-fluendo-mp3 flashplugin-nonfree

if not install them using apt-get

share|improve this answer
    
I do have those packages installed. I don't know why but now the sound test doesn't work either there was never any sound, but the icons changed. And the speaker icon in the top right corner disappeared. I can still adjust the volume with buttons on laptop and sound settings and alsamixer. Thanks for your response. –  Frank Oct 24 '13 at 20:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.