Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today the update-manaeger suggested that I should download some updates. So I did. After the updates were installed I had to reboot the system.

After the reboot my notebook doesn't see any wireless networks.

I was looking for a long time on the internet for answers but non of them applies to my case.

I have the idea, it has got something to do with the kernel I am currently using (Linux 3.2.0-55). Is this one new for Ubuntu 12.04?

When I boot my system I can choose to use an older kernel (linux 3.2.0-32). When I use this one the notebook does see the wireless networks.

This is my network card according to the command lspci: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

Anyone an idea to fix my problems with wireless internet?

share|improve this question
    
Did you install that driver by compiling it? –  Wild Man Oct 23 '13 at 17:41
    
I don't understand what you mean. I never installed drivers, I bought the notebook with ubuntu 12.04 and all the drivers installed on it. This morning after some updates I found out my wireless card was somehow disabled ( I could not see any networks and I could not adjust any settings for the wireless network.) I did a recovery and after that the wireless card was working again. But after downloading a lot of updates the problem occured again. –  Bastian Oct 23 '13 at 19:49
    
It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. No internet then go to this link for running the script without internet. [url]ubuntuforums.org/showpost.php?p=12350385[/url] –  Wild Man Oct 23 '13 at 20:08
    
Should I run this when I boot the notebook with the 3.2.0-55 generic kernel or can it also be done with the 3.2.0-32 generic kernel? –  Bastian Oct 23 '13 at 20:17
    
With the one you are having issues with or both for comparison. –  Wild Man Oct 23 '13 at 20:18

2 Answers 2

Your device is supported by the kernel that came with your computer it was made to work from the manufacturer, so when you do an update to your system that includes a kernel update your wireless will stop working.

You can go into synaptic package manager and choose to lock the kernel so when you update you do not receive kernel updates or you can install 13.04 that supports your device by default.

You may have to install synaptic it does not come installed by default any more.

Also you can do:

sudo modprobe -v rt2800pci 

see if that turns it on but I believe with the update it will not work any more.

If you wish to install synaptic package management do:

sudo apt-get install synaptic

then open synaptic>type the kernel version that you want to lock into the filter window at the top of synaptic>click on that kernel version>then click on package at the top of the window>then lock version. Now when you update it should not break your wireless.

Edit: Added screenshots. synapticlock kernel

share|improve this answer
    
You were right about sudo modprobe -v rt2800pci, that does not work. One more question, Should I keep 12.04 LTS or switch to 13.04? Or to 13.10 ? –  Bastian Oct 24 '13 at 8:18
    
I like 12.04 because it is stable and supported for 5 years but I have not used 13.04 and 13.10 just came out it needs more time to become stable but it is only supported for six months I believe. –  Wild Man Oct 24 '13 at 15:01
    
That is what it should look like after it is locked, if it does then I would run the update. –  Wild Man Oct 24 '13 at 15:25
    
Make sure this is the one you lock 3.2.0-32. –  Wild Man Oct 24 '13 at 16:42
    
I think it will work if it does please accept the answer so it will benefit everyone. –  Wild Man Oct 24 '13 at 17:36

Ok I had the same problem a while ago. I locked the kernel from synaptic as Wild Man explained. But then I solved my problem of installing the drivers properly by following this tutorial of Luis Alvarado in Askubuntu♦

How do I get a Ralink RT3290 wireless card working?

Hope that will help!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.