Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everytime i type juju bootstrap .Error no default environment found keeps showing up. I was trying to configure maas.

This is my environments.yaml

juju: environments
environments:
maas:
type: maas
maas-server: 'http://{my ip address}:80/MAAS'
maas-oauth: 'c2cg7hTpzFuRmJjrBC:YH2ZEXVRKL46ttaDmq:beKeBjhYgWyxKk2gqqwaCx97xnmp4LJu'
admin-secret: 'nothing'
default-series: 'precise'
share|improve this question
add comment

1 Answer 1

Even with only one environment specified in environments.yaml, you still need to specify a default environment for juju to use.

You have 2 options to specify a default environment:

  1. Using default: <name>, usually at the top of environments.yaml, without indentation (in your case, you'll need default: maas).
  2. Using juju switch <name> on the command line (e.g. juju switch maas).

I hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.