Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ive been really struggling to get my nvidia card working with bumblebee. Currently when i run optirun glxspeheres i get the following.

    [  138.520664] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

    [  138.520772] [ERROR]Aborting because fallback start is disabled.

Ive tried a number of things that have been mentioned on here, the latest being the installation of the nvidia-319 (although this seemed to install nvidia-331 confusingly) and then the re-configuration of bumblebee. My /etc/bumblebee/bumblebee.conf is as follows

[bumblebeed]
VirtualDisplay=:8

KeepUnusedXServer=false
ServerGroup=bumblebee
TurnCardOffAtExit=false
NoEcoModeOverride=false
Driver=nvidia
XorgConfDir=/etc/bumblebee/xorg.conf.d

[optirun]
Bridge=auto
VGLTransport=proxy
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
AllowFallbackToIGC=false

[driver-nvidia]
KernelDriver=nvidia-331
PMMethod=auto
LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331
XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Can someone please give me a clue as to what to do to get this working. I'll happily post logs or command output if someone can let me know what would be useful.

Many thanks

Mark

share|improve this question
add comment

1 Answer 1

1

Open the terminal (alt+ctrl+T) and type or copy/paste

gksu nautilus /etc/bumblebee/bumblebee.conf

Now change this line:

LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331

to this:

LibraryPath=/usr/lib/nvidia:/usr/lib32/nvidia-331

Save the file (ctrl+s) and close the textfile, folder and terminal.

2

Open the terminal again and type or copy/paste

gksu nautilus /etc/bumblebee/xorg.conf.nvidia

and change:

#"BusID PCI:01:00:0"

to this:

BusID "PCI:01:00:0"

Once again, save the file, close the file and the folder and close the terminal.

Reboot into ubuntu. After rebooting open a terminal and type or copy/paste:

optirun glxspheres

I hope this solves your issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.