Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to install VLC by terminal this shows up.

ankit@ankit-desktop:~$ sudo apt-get install vlc
[sudo] password for ankit: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.0.8+git20131023+r618-0~r13~ubuntu13.10.1) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.0.8+git20131023+r618-0~r13~ubuntu13.10.1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.0.8+git20131023+r618-0~r13~ubuntu13.10.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I'm using Ubuntu 13.10.

Please tell me what to do?

When I try to install VLC from software center, this message pops up, Package dependencies cannot be resolved.

share|improve this question
    
Do you have any third party PPAs enabled? –  Anwar Shah Oct 23 '13 at 14:23
    
I don't know. How to check it? –  Ankit Oct 23 '13 at 15:21
    
You have the VLC PPA enabled; you can tell because the package names include +git[date] (e.g., vlc-nox_2.0.8+git20131023+r618-0~r13~ubuntu13.10.1_i386.deb). I haven't had any problems upgrading my VLC about the time you asked your question, but I'm running 12.04. Try again later. –  carnendil Oct 23 '13 at 15:37

2 Answers 2

Try to run:

sudo apt-get -f install

This should fix broken packages or unmet dependencies. Then you can go about installing vlc.

share|improve this answer
    
Did it. But it didn't help. The problem is still there. –  Ankit Oct 23 '13 at 15:11

It seems you have Third party PPAs enabled. Disable them. See this question

Now refresh your package list with sudo apt-get update and do sudo apt-get install -f to solve the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.