Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use the optical audio output of my motherboard to send the sound to my AV Receiver.

I only see the front channels received by my AV.

Indeed rear channels don't seem to be activated.

Sound settings

How can I activate the rear channels ?

share|improve this question
add comment

2 Answers 2

You can't. S/pdif support PCM, AC3 and DTS (if your decoder support them) PCM only support stereo up to 24bit/192khz

AC3 and DTS support surround. But they are patented technologies and not open-source friendly. As far as I know, ther is no way to get Ubuntu to transcode on the fly to AC3 or DTS to feed S/PDIF

share|improve this answer
add comment

I have the same problem, I can see from your post it's since October 2013, hope it's not too late.

This post should solve your problem (theoretically), it didn't solve my problem however I have seen others who posted success results for applying that solution, worth trying.

https://help.ubuntu.com/community/DigitalAC-3Pulseaudio

After installing the AC3 plugin, you will need to keep pavucontrol up. That's right - Just don't close it.

Select one of the two Digital Surround 5.1 profile options (one includes Analog input) under the built-in audio section under the configuration tab of pavucontrol then DON'T CLOSE that app, you will get working 5.1 audio in all other programs.

If you close it, you won't get the surround sound.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.