Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This question already has an answer here:

I've downloadad the latest XAMPP file, to install it into Ubuntu 13.04.

After downloading the file, I just can run it.

I've double click it (and I've tried right click and clicking "open", whith the same result).

All the answer I get is this message:

Could not display “”. There is no application installed for “executable” files. Do you want to search for an application to open this file?

I've tried searching for an application, with no result...

Also, I haven't found any questions related to this issue with the 13.04 Unity version... I've tried this solution, with no result.

Please note that this isn't a Xampp question, the same happened to me when I tried to install Skype.


I've tried this solution:

cd ~/Downloads

chmod +x

sudo sh

And I've got this error:

Syntax error: "(" unexpected

What should I do? Thanks!

share|improve this question

marked as duplicate by dobey, karel, guntbert, belacqua, LiveWireBT Oct 24 '13 at 0:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

What's the problem with packaged software? –  Luís de Sousa Oct 23 '13 at 7:12
Have a look here. You need to change permission to allow executing, as mentioned in the link. Then, open a terminal, navigate to the folder, and type ./xampp-linux...restofname. –  mattblang Feb 8 '14 at 2:52

1 Answer 1

up vote 1 down vote accepted

Step 1 Move the .run to your Home folder

Step 2 Right-click on the file and select Properties

Step 3 Under the Permissions tab, tick the checkbox Allow executing file as program. Click Apply.

Step 4 Double click the file to run


Here is how to execute .run or .bin files

Step 1: Open the terminal and execute following command

$chmod +x

Step 2: Execute the file


If you have any trouble or want to do it using GUI instead of terminal see this link

share|improve this answer
Thanks for your reply! I've tried both ways, and nothing happens. In the command line way, it won do anything, it just acts as id I only pressed "enter". The GUI way, nothing happens, as if I didn't double clicked the file. –  Rosamunda Oct 23 '13 at 4:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.