Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.10 and everything works great except there is no audio. I am using a Radeon 6770 connected via HDMI to my TV but under sound settings there is only analog or digital options. I would greatly appreciate any help to fix this issue.

share|improve this question
    
In 'Software and Updates' have you tried enabling Additional Drivers? –  Pieter Oct 24 '13 at 11:14
add comment

5 Answers 5

Try the below code in terminal

sudo gedit /etc/default/grub

Edit the line

GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX="radeon.audio=1"

Run:

 sudo update-grub

Restart the system

Alternatively, and if this does not work, consider installing the proprietary driver for your ATI graphics card.

share|improve this answer
1  
Why downvote? This is the recommended way of enabling HDMI audio for the open radeon driver. –  Takkat Oct 23 '13 at 6:33
    
Whom ever edited it.. thank you. I probably should have made it a little more readable. –  Chris Oct 23 '13 at 6:40
add comment

Run the following and reboot

sudo sed -i 's/LINUX_DEFAULT="/LINUX_DEFAULT="radeon.audio=1 /g' /etc/default/grub
sudo update-grub

This should enable HDMI audio which may be disabled by default.

Also, I would advise adding the oibaf PPA for the latest optimized open source drivers for your GPU:

sudo add-apt-repository -y ppa:oibaf/graphics-drivers; sudo apt-get update; sudo aptitude upgrade -y; sudo aptitude dist-upgrade -y; sudo aptitude install xserver-xorg-video-all -y
share|improve this answer
    
I tried it and it still won't show an HDMI option in sounds. –  user206102 Oct 22 '13 at 23:20
add comment

Your Radeon 6770 is only a graphic or video card as I could check. If you have a desktop, which I think you are using now, the PCI where you connect the HDMI device would work only in a video device. In order to get a good quality sound you need a sound card, and since you are using an HDMI cable, you will also need separate speakers. In my case, I have it connected to my TV via HDMI but I have a Craig speaker with bass using the regular output sound, even thou my MB is equip with 5.1 sound.

share|improve this answer
    
So there's no workaround to this problem other than getting speakers? On windows I have it set up the same way and I get sound from my video card via HDMI. –  user206102 Oct 23 '13 at 2:50
add comment

In my case this was due to the fact that upgrading introduced a new volume control interface that conflicted with the old one (which is still installed). Clicking on the sound indicator in the panel and choosing Sound Settings got me this controller:

New sound interface 1/2

It was showing HDMI selected, and sound being output, as above, but no sound was coming out of the speakers. In the last tab, I had the option of setting HDMI to 'off', as in this screenshot:

New sound interface 2/2

Doing so switched the sound over to analog, and I got sound from the speakers. (I've got dual input on my speakers; they're connected directly to the computer with the analog output, and to the TV I use as a monitor, which is receiving the HDMI output.) Then I went to System Settings --> Sound, and discovered that the old interface (the one that the sound indicator linked to in 13.04 and earlier) is the one that showed up, as pictured below:

enter image description here

In this settings dialog, analog output was selected. Since I had set HDMI to 'off' in the other interface, I no longer saw the HDMI option. Turning HDMI back on in the first interface and rebooting brought back the HDMI option, and selecting it restored HDMI sound. So my guess is that one interface had HDMI selected while the other had analog selected, but that's just my guess.

share|improve this answer
    
I should add that I have the proprietary AMD driver installed to enable HDMI audio without changing any boot flags, and the driver was left unchanged by the upgrade. –  Sean Fitzpatrick Oct 27 '13 at 14:48
add comment

I have a Samsung Laptop R620 and I had no sound. When I installed 13.10 (upgraded from 12.10). Sound settings only displayed built in speakers which operated under test okay. Then tried wav file which did not work. Missing codecs. Loaded Rhythmbox with all the codecs selected and low and behold I now had HDMI sound output under sound settings as well as built in speakers. Checked both wav file and HDMI ouput and okay. Had to select they required one. I think that there is a little glitch in the installation procedure.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.