Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Just bought this little Asus 10 inch laptop that came with Ubuntu 12.04. Everything at my home was fine: Wireless identified and connected.

As soon as I went to my girlfriend's house the trouble started.

I couldn't connect to wireless (authentication... times out and asks for authentication)

I started doing internet searching, tried a few solutions posted on line using terminal commands. No solutions. I decided to upgraded to 12.10-13.04 and that left me with a worse problem: I can no longer see ANY networks what so ever.

Wireless card is ON, with out a doubt. Wired connection works.

I have been fumbling with driver versions to no .avail, and have no idea which driver I am currently running

I have a vague idea of what terminal lines to run:

lshw:
  resources: irq:17 memory:f7d00000-f7dfffff
           *-network
                description: Wireless interface
                product: BCM4313 802.11b/g/n Wireless LAN Controller
                vendor: Broadcom Corporation
                physical id: 0
                bus info: pci@0000:02:00.0
                logical name: eth2
                version: 01
                serial: dc:85:de:56:c4:ea
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg
                resources: irq:17 memory:f7d00000-f7d03fff

iwconfig:
eth1      no wireless extensions.

eth2      IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

I am new and excited to start my Ubuntu and Linux life and this is only the first of my few hic cups i am sure! :) Thanks all

UPDATE: Report from 2nd answer

talon@Black1015E:~$ sudo apt-get remove --purge bcmwl-kernel-source
[sudo] password for talon: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'bcmwl-kernel-source' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
talon@Black1015E:~$ wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb
--2013-10-22 18:50:32--  http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb
Resolving us.archive.ubuntu.com (us.archive.ubuntu.com)... 2001:67c:1562::15, 2001:67c:1562::13, 2001:67c:1562::14, ...
Connecting to us.archive.ubuntu.com (us.archive.ubuntu.com)|2001:67c:1562::15|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1181334 (1.1M) [application/x-debian-package]
Saving to: ‘bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb’

100%[======================================>] 1,181,334   3.37MB/s   in 0.3s   

2013-10-22 18:50:33 (3.37 MB/s) - ‘bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb’ saved [1181334/1181334]

talon@Black1015E:~$ arvh
No command 'arvh' found, did you mean:
 Command 'arch' from package 'coreutils' (main)
arvh: command not found
talon@Black1015E:~$ arch
x86_64
talon@Black1015E:~$ sudo dpkg -i bcmwl*.deb
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 171895 files and directories currently installed.)
Unpacking bcmwl-kernel-source (from bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb) ...
Setting up bcmwl-kernel-source (5.100.82.112+bdcom-0ubuntu3) ...
Loading new bcmwl-5.100.82.112+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 3.8.0-32-generic
Building for architecture x86_64
Building initial module for 3.8.0-32-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.8.0-32-generic/updates/dkms/

depmod........

DKMS: install completed.
Error: Module b43 is not currently loaded
Error: Module b43legacy is not currently loaded
Error: Module ssb is not currently loaded
Error: Module bcm43xx is not currently loaded
Error: Module brcm80211 is not currently loaded
Error: Module brcmfmac is not currently loaded
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-32-generic

rebooting now

share|improve this question

marked as duplicate by Luis Alvarado Oct 23 '13 at 16:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Please try:

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -rv wl
sudo modprobe -v brcmsmac

if there are any errors please continue with the commands then reboot. If you have not installed any other drivers but the wl driver then your wireless should be working.

share|improve this answer
    
sudo apt-get purge bcmwl-kernel-source [sudo] password for talon: Reading package lists... Done Building dependency tree Reading state information... Done Package 'bcmwl-kernel-source' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. talon@Black1015E:~$ talon@Black1015E:~$ talon@Black1015E:~$ sudo modprobe -rv wl FATAL: Module wl not found. talon@Black1015E:~$ sudo modprobe -v brcmsmac talon@Black1015E:~$ rebooting now –  TalonPlz Oct 22 '13 at 22:40
    
Did your wireless come alive if not follow chili555 directions. –  Wild Man Oct 22 '13 at 22:42
    
Hey Wildman, it didn't. Now my Wifi isn't even on (confusing)... under the connections drop down its unchecked and greyed out. P.S. Thanks for being on these forums man. I saw some of your troubleshooting on posts as I searched for answers. appreciate your help –  TalonPlz Oct 22 '13 at 22:47

In Ubuntu 13.04, I believe the default bcmwl-kernel-source will not work correctly for your Broadcom 4313. I recommend that you get a temporary wired ethernet connection and open a terminal:

sudo apt-get remove --purge bcmwl-kernel-source
wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb

Or, if yours is a 32-bit system:

wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_i386.deb

Confirm 32- or 64-bit:

arch

Then do:

sudo dpkg -i bcmwl*.deb

Reboot and give us your report.

Detach the ethernet. Is the module wl loaded?

lsmod | grep wl

If not, load it explicitly:

sudo modprobe wl

How about now? Does the interface scan?

sudo iwlist eth1 scan
share|improve this answer
    
Hey Chili, I posted results as an edit because they were too long to put in a comment. It looks like that hasn't solved anything for me. GUI shows no wireless options what so ever now. Not sure what's up –  TalonPlz Oct 22 '13 at 23:03
    
iw config shows: iwconfig eth1 no wireless extensions. lo no wireless extensions. –  TalonPlz Oct 22 '13 at 23:13
    
eth2 is gone :/ –  TalonPlz Oct 22 '13 at 23:13
    
See my edits above. –  chili555 Oct 22 '13 at 23:19
    
The terminal had nothing to say to those commands: talon@Black1015E:~$ lsmod | grep wl talon@Black1015E:~$ lsmod | grep wl talon@Black1015E:~$ sudo modprobe wl [sudo] password for talon: talon@Black1015E:~$ sudo iwlist eth1 scan eth1 Interface doesn't support scanning. –  TalonPlz Oct 22 '13 at 23:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.