Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Ubuntu Server with Plesk insalled. My Englisch and my "linux" ist not very great!

Since a few Days my PHP doesn't work. If i load a php site my Browser download the php file instead of parsing the php code.

root@v41251:~# sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  php5-sqlite
The following packages will be upgraded:
  php5-sqlite
1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
3 not fully installed or removed.
Need to get 0 B/27.6 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 80740 files and directories currently installed.)
Preparing to replace php5-sqlite 5.3.10-1ubuntu3.6 (using .../php5-sqlite_5.3.10-    1ubuntu3.8_amd64.deb) ...
Unpacking replacement php5-sqlite ...
dpkg: error processing /var/cache/apt/archives/php5-sqlite_5.3.10-    1ubuntu3.8_amd64.deb (--unpack):
 unable to install new version of `/usr/share/doc/php5-sqlite': No such file or     directory
No apport report written because the error message indicates an issue on the local  system
                                                                                                 Processing triggers for libapache2-mod-php5 ...
Action 'configtest' failed.
The Apache error log may have more information.
Your apache2 configuration is broken, so we're not restarting it for you.
Errors were encountered while processing:
  /var/cache/apt/archives/php5-sqlite_5.3.10-1ubuntu3.8_amd64.deb
 E: Sub-process /usr/bin/dpkg returned an error code (1)

If i tried to uninstall apache2, I get the following message

The following packages have unmet dependencies:
 php5-sqlite : Depends: php5-common (= 5.3.10-1ubuntu3.6) but 5.3.10-1ubuntu3.8 is to be installed

The same with php5-common

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5 : Depends: php5-common (>= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5-cgi : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5-cli : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5-curl : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5-gd : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5-mysql : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 php5-sqlite : Depends: php5-common (= 5.3.10-1ubuntu3.6) but it is not going to be installed
 php5-xsl : Depends: php5-common (= 5.3.10-1ubuntu3.8) but it is not going to be installed
 psa-php5-configurator : Depends: php5-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I also tried sudo apt-get clean, sudo apt-get autoclean, sudo dpkg --configure -a but my Linux knowledge is very small

I also tried to comment out the last files from /etc/apache2/mods-available/php5.conf

Now the Configuration File of my apache is destroyd, so I cant restart my apache.

root@v41251:~# sudo /etc/init.d/apache2 reload
apache2: Syntax error on line 214 of /etc/apache2/apache2.conf: Could not open     configuration file /etc/apache2/httpd.conf: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

And i tried to reinstall my apache with

sudo apt-get remove --purge $(dpkg -l apache* | grep ii | awk '{print $2}') && sudo apt-get install apache2

Can you help me?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.