Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I’m trying to install Windows 7 Professional as a KVM guest using virt-install with an ISO file on my Ubuntu 13.04 via command line. Using the following commands:

root@ziomario-Macmini:/# sudo invoke-rc.d apparmor stop

  • Clearing AppArmor profiles cache [ OK ] All profile caches have been cleared, but no profiles have been unloaded. Unloading profiles will leave already running processes permanently unconfined, which can lead to unexpected situations.

To set a process to complain mode, use the command line tool 'aa-complain'. To really tear down all profiles, run the init script with the 'teardown' option."

root@ziomario-Macmini:/# sudo update-rc.d -f apparmor remove

Removing any system startup links for /etc/init.d/apparmor ... /etc/rcS.d/S37apparmor

root@ziomario-Macmini:/# chmod go+rx /media/ziomario/09274c80-4a49-4f4f-9e2e-83c4a5578a04/OS/kvm-windows/downloaded

root@ziomario-Macmini:/# chmod o-rwx /media/ziomario/09274c80-4a49-4f4f-9e2e-83c4a5578a04/OS/kvm-windows/downloaded/*

root@ziomario-Macmini:/# sudo virt-install --connect qemu:///system -n win7_pro -r 800 -c /media/ziomario/09274c80-4a49-4f4f-9e2e-83c4a5578a04/OS/kvm-windows/downloaded/X17-58997.iso --vnc --noautoconsole --os-type windows --os-variant win7 --disk /dev/sdd1,size=1000 --accelerate

Starting install... ERROR internal error process exited while connecting to monitor: char device redirected to /dev/pts/5 (label charserial0)

kvm-spice: -drive file=/media/ziomario/09274c80-4a49-4f4f-9e2e-83c4a5578a04/OS/kvm-windows/downloaded/X17-58997.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw:

could not open disk image /media/ziomario/09274c80-4a49-4f4f-9e2e-83c4a5578a04/OS/kvm-windows/downloaded/X17-58997.iso: Permission denied

Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start win7_pro otherwise, please restart your installation.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.