Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm able to set either everything Finnish or everything English. I want to have Finnish keyboard layout, but the OS language in English. How to do this? In the previous releases I didn't have to do anything.

share|improve this question
    
I use Swedish layout with English as system language, works perfect. –  Alvar Dec 27 '13 at 18:49

2 Answers 2

up vote 5 down vote accepted

How to keep the system language in English

First, go to System SettingsLanguage Support and in Langage tab, apply system wide English:

Language Support

In Regional Formats apply system wide your favorite English:

Regional Formats

Second, go to System SettingsUser Accounts and select English as your language:

User Accounts

How to change keyboard layout to Finnish

Go to System SettingsText Entry and add Finnish keyboard layout:

Text Entry

See also: Language problem in Ubuntu 13.10

share|improve this answer
1  
I have two objections to this answer. First: Regional formats is a third aspect that is not mentioned in the question. It's likely that a Finnish user prefers regional formats that are typical for Finland rather than the US. Second: If you have set the user language from Language Support (which you do by controlling which option is on top of the list), there is no reason to also go to User Accounts. –  Gunnar Hjalmarsson Oct 22 '13 at 21:59
    
There's still something horribly wrong, because my Qt apps are using Finnish translations even though the system language is now English and Finnish language support is not even installed. If I set LANG=en_US.UTF-8 when starting the app it's still in Finnish. It seems that the whole locale/keyboard layout system in 13.10 is a mess. Everything worked just fine under 13.04. –  user205301 Oct 23 '13 at 6:41
    
@user205301 That's because you have installed them in Finnish language. Try to change their language from their menus. –  Radu Rădeanu Oct 23 '13 at 6:45
    
In my case there are no menus. Qt should switch the language based on LANG anyway. It worked before. –  user205301 Oct 23 '13 at 6:50
1  
@user205301: Ubuntu works with LANGUAGE, too, not only LANG. If you open Language Support and change the selected language to something else, and then back to what you want, it should be ok next time you log in. –  Gunnar Hjalmarsson Oct 23 '13 at 14:38

Having installed your system in English, add a Finnish keyboard layout. Then configure how to change between layouts.

But if you are going to make a brand new installation of Ubuntu, there is a step in the installation process (Nº 10 in this answer) where it asks you to set your keyboard layout.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.