Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have just upgraded my Ubuntu 13.04 to 13.10. All things working fine but I can't change my desktop wallpaper. Whenever I try to change,it changes to solid color only. I'm using the GNOME desktop, not Unity.

Please help me out

share|improve this question
    
You have all done with edited my question, thanks for that but now where is the answer ??? –  Gurupal singh Oct 23 '13 at 4:52
    
there are the answers ^ –  Braiam Nov 27 '13 at 1:09
add comment

marked as duplicate by guntbert, Braiam, karel, Seth, Eric Carvalho Nov 27 '13 at 12:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

From Desktop shows a white or black background instead of wallpapers:

Open terminal by pressing Crl+Alt+t and use

gsettings set org.gnome.settings-daemon.plugins.background active true
share|improve this answer
    
Thanks for the answer –  Gurupal singh Nov 27 '13 at 7:40
add comment

I had this problem because I mostly use xfce4 and had set nautilus to not control the desktop (nautilus --no-desktop). Switching over to Unity, I had no wallpaper.

Try opening a terminal and type

nautilus --force-desktop &

(thats 2 dashes before force and one after)

If you get your wallpaper back it means nautilus isn't controlling the desktop at the moment.

I used to be able to use Ubuntu Tweak to set that switch but it isn't showing up in mine (version 0.8.6).

You could also try downloading gnome-tweak-tool and set the switch in it. This is my first time answering and the formatting is too hard to figure out at 2:24 am so I hope you can make sense of this :)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.