Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing Ubuntu Touch on my Nexus 4. When I try to boot, it's stuck at the google screen. Any ideea how to solve this? I mean booting to ubuntu, I know how to get back to recovery.

share|improve this question
    
Please don't re-ask the same question. askubuntu.com/questions/362607/ubuntu-touch-boot-problem –  gertvdijk Oct 23 '13 at 10:33
add comment

1 Answer

Happened to me when I forgot to flash the "saucy-preinstalled-touch-armhf.zip" it's the one file that doesn't belong to a specific device

What I had done, to make it work:

  • Installed USB drivers for the phone (make sure that you can use adb in recovery mode)
  • execute: fastboot oem unlock
  • restart phone into fastboot
  • execute: fastboot flash recovery <...recovery....+[DEVICE NAME].img>
  • execute: fastboot flash boot <...boot....+[DEVICE NAME].img>
  • execute: fastboot flash system <...system....+[DEVICE NAME].img>
  • go to recovery
  • adb push <...touch....+[DEVICE NAME].zip> /sdcard/autodeploy.zip
  • restart device to recovery, so it will apply the zip device might restart - if it does, go again to recovery
  • adb push <...touch....-armhf.zip> /sdcard/autodeploy.zip
  • restart device to recovery, so it will apply the zip

Ubuntu touch loaded after this. Note that there is no splash screen, and while it loads, my screen was dark. just wait a minute.

share|improve this answer
1  
can you add more details about how to flash "saucy-preinstalled-touch-armhf.zip", it would be much better if you can provide all the steps you followed to resolve the issue. –  VRU Oct 22 '13 at 18:12
    
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  qbi Oct 22 '13 at 19:06
    
I used the 'Manual Download & Installation' from here. I had the same symptom when I forgot to push the last file mentioned there (saucy-preinstalled-touch-armhf.zip). Re-did it according to the instructions and everything worked. –  uvgroovy Oct 22 '13 at 22:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.