Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to 13.10, every time I boot I'm shown a login prompt (tty1) for ~30 seconds before lightdm automatically starts.

Everything works fine after that. Any ideas on what I could try to fix/debug this?

My /var/log/lightdm/x-0-greeter.log contains lines like the following:

** (at-spi2-registryd:1381): WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
** (at-spi2-registryd:1381): WARNING **: Unable to register client with session manager
WARNING: Failed to open sessions directory: Error opening directory '/usr/share/lightdm/sessions': No such file or directory
** Message: PID 1534 (we are 1534) sent signal 15, shutting down...
** (gnome-settings-daemon:1401): WARNING **: Name taken or bus went away - shutting down

Searching for these errors results in a variety of bugs filed over the years. Maybe a clean install will fix this.

share|improve this question
    
You sure you have quiet splash in your grub? –  Braiam Oct 23 '13 at 0:54
    
/etc/default/grub contains: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" –  David Weldon Oct 23 '13 at 1:57
add comment

1 Answer 1

up vote 1 down vote accepted

A recent update seems to have fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.