Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu Gnome 13.10 on my computer yesterday, and everything seems to be working fine so far, except that it isn't reading video or audio CD's and DVD's. At first, I inserted a DVD video, and it played normally for maybe 30-45 seconds before coming up with a "internal read error" or something like that. I was using the Totem player when the problem occurred, so I tried to install the VLC media player.

It wouldn't read the disc at all, so I uninstalled the player. Now, the Totem player won't even begin playing the DVD. The player sometimes doesn't even open up when I insert the DVD, and other times it will but says it can't read it. I've tried several different DVD's and CD's with similar results. The computer is recognizing the optical drive, because when I open "Files", it shows the drive and the disc, but can't play it. Previously, I ran Ubuntu 13.04 with the Gnome desktop installed from the software center, and I had no issues. Any help is appreciated!

share|improve this question
    
I've tried all the usual ideas, like installing VLC, encryption libraries, region codes, etc. The error that comes up is "internal data flow error". I can't believe no one else has been having this problem! I've had this issue every time I install 13.10 on a computer, in both Unity and Gnome desktops. It's been the same thing with 3 or 4 different computers. Thanks for your help! –  John Hill Nov 12 '13 at 7:02
    
Same system, same problem, sorry no answers yet. –  Dennis Nov 16 '13 at 23:23

5 Answers 5

Well it seems that your DVD's are encrypted. In this case, installing the restricted packages only would not help. You would also need to install libdvdcss to play encrypted DVD's. Run this from terminal:

sudo /usr/share/doc/libdvdread4/install-css.sh

Also remember you need to have libdvdread4 installed before running the above code. You may not need to install libdvdread4 since you have already installed ubuntu-restricted-extras. A reboot may be necessary after running the script. For more reference you can view: RestrictedFormats/PlayingDVDs

share|improve this answer

1 - Open Terminal

2 - Copy & Paste Command

sudo apt-get install ubuntu-restricted-extras

3 - Press Enter

4 - Enter Your Password

5 - Press Enter

Ubuntu Restricted Extras will now be installed, giving you the opportunity to watch DVD's.

share|improve this answer
1  
Use VLC Media player from Ubuntu Software center its play Most of the all formats –  Lonston Oct 22 '13 at 4:24
    
Thanks for the help, but that didn't work. I installed the Ubuntu restricted extras and rebooted, but have the same problem. Any other ideas? –  John Hill Oct 22 '13 at 4:44

you need to install both of them.so in short.

1.open terminal

2.enter into terminal

sudo apt-get install ubuntu-restricted-extras

3.enter password.

4.enter into terminal

sudo /usr/share/doc/libdvdread4/install-css.sh

5.you are done.

you may also want to read this

NOTE

Patent and copyright laws operate differently depending on which country you are in. Please obtain legal advice if you are unsure whether a particular patent or restriction applies to a media format you wish to use in your country.

share|improve this answer

Ok, I finally found the answer that worked for me on two different machines! First, run in the terminal:

sudo apt-get install regionset vlc

That installs the region code stuff and the VLC Media Player.

Then run another command in the terminal:

sudo /usr/share/doc/libdvdread4/install-css.sh

It might be a good idea to reboot before using. Hope this works for everybody else!

share|improve this answer

The original poster is probably experiencing this bug which originates in gstreamer, the software used for reading the video stream. The best way to find out if your're affected by the bug is to launch totem player in the terminal console and see if the console displays such message (or very similar) upon hitting the error:

** (totem:7868): CRITICAL **: gst_video_decoder_allocate_output_frame: assertion 'frame->output_buffer == NULL' failed 

This bug has already been resolved in the gstramer software but the fix still need to find its way to Ubuntu. In the meantime installing VLC, which uses its own software for decoding, should be fine for playing DVD.

Some may find it useful to set VLC as the default player for videos and DVD/removable medias as explained there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.