Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Almost a complete newb here. After my last upgrade from 12.04 to 13.10 my wifi now randomly drops. The only way I can get a signal back is a shutdown and restart otherwise it shows no network is even available to connect to. Had no problems until the upgrade. Any help would be appreciated.

H/W path         Device      Class       Description
====================================================
                         system      h8-1534 (H2N64AA#ABA)
/0                           bus         2AC8
/0/0                         memory      64KiB BIOS
/0/4                         processor   AMD FX(tm)-6200 Six-Core Processor
/0/4/5                       memory      288KiB L1 cache
/0/4/6                       memory      6MiB L2 cache
/0/4/7                       memory      8MiB L3 cache
/0/d                         memory      10GiB System Memory
/0/d/0                       memory      DIMM Synchronous [empty]
/0/d/1                       memory      4GiB DIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/d/2                       memory      2GiB DIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/d/3                       memory      4GiB DIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/100                       bridge      RD890 PCI to PCI bridge (external gfx0 port B)
/0/100/0.2                   generic     RD990 I/O Memory Management Unit (IOMMU)
/0/100/2                     bridge      RD890 PCI to PCI bridge (PCI express gpp  port B)
/0/100/2/0                   display     Turks PRO [Radeon HD 7570]
/0/100/2/0.1                 multimedia  Turks/Whistler HDMI Audio [Radeon HD 6000  Series]
/0/100/5                     bridge      RD890 PCI to PCI bridge (PCI express gpp port E)
/0/100/5/0                   bus         TUSB73x0 SuperSpeed USB 3.0 xHCI Host Controller
/0/100/11                    storage     SB7x0/SB8x0/SB9x0 SATA Controller [RAID5 mode]
/0/100/12                    bus         SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/12.2                  bus         SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/13                    bus         SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/13.2                  bus         SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/14                    bus         SBx00 SMBus Controller
/0/100/14.2                  multimedia  SBx00 Azalia (Intel HDA)
/0/100/14.3                  bridge      SB7x0/SB8x0/SB9x0 LPC host controller
/0/100/14.4                  bridge      SBx00 PCI to PCI Bridge
/0/100/14.5                  bus         SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
/0/100/15                    bridge      SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
/0/100/15.1                  bridge      SB700/SB800/SB900 PCI to PCI bridge (PCIE port 1)
/0/100/15.2                  bridge      SB900 PCI to PCI bridge (PCIE port 2)
/0/100/15.2/0    wlan0       network     RT3290 Wireless 802.11n 1T/1R PCIe
/0/100/15.2/0.1              generic     RT3290 Bluetooth
/0/100/15.3                  bridge      SB900 PCI to PCI bridge (PCIE port 3)
/0/100/15.3/0    eth0        network     RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/16                    bus         SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/16.2                  bus         SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/101                       bridge      Family 15h Processor Function 0
/0/102                       bridge      Family 15h Processor Function 1
/0/103                       bridge      Family 15h Processor Function 2
/0/104                       bridge      Family 15h Processor Function 3
/0/105                       bridge      Family 15h Processor Function 4
/0/106                       bridge      Family 15h Processor Function 5
/0/1             scsi0       storage     
/0/1/0.0.0       /dev/sda    disk        1TB WDC WD1002FAEX-0
/0/1/0.0.0/1                 volume      189MiB Windows FAT volume
/0/1/0.0.0/2     /dev/sda2   volume      244MiB data partition
/0/1/0.0.0/3     /dev/sda3   volume      931GiB LVM Physical Volume
/0/2             scsi2       storage     
/0/2/0.0.0       /dev/cdrom  disk        DVD A  DH16ACSHR
/0/3             scsi6       storage     
/0/3/0.0.0       /dev/sdb    disk        SCSI Disk
/0/3/0.0.1       /dev/sdc    disk        SCSI Disk
/0/3/0.0.2       /dev/sdd    disk        SCSI Disk
/0/3/0.0.3       /dev/sde    disk        MS/MS-Pro
/0/3/0.0.3/0     /dev/sde    disk        
/1                           power       Standard Efficiency

I apologize for my newbness. I hope this is enough info for the hardware. Thanks Bruno for pointing out I needed to add more info. If I am lacking anything else please let me know and I'll post it.

share|improve this question

closed as unclear what you're asking by Bruno Pereira Oct 21 '13 at 21:19

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You need to give us more information about the kind of hardware you are using. askubuntu.com/questions/31618/… –  Bruno Pereira Oct 21 '13 at 21:20
1  
In particular please do sudo lshw -c network. –  poolie Oct 23 '13 at 3:29
1  
How did you got that output??? What we need is what poolie said or sudo lspci -nnk | grep net -A2. –  Braiam Oct 23 '13 at 3:36

Browse other questions tagged or ask your own question.