Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a fresh install of Ubuntu 13.10 (actually, I've done two fresh installs, hoping that trying again would get this working).

I don't seem to have the ability to add or remove bookmarks from Nautilus. The ones that are there by default (Home, Desktop, Documents, etc.) work fine. I can right click on them and rename them. However, I cannot remove any of them. The option is there "Remove" but disabled/grayed out.

The same is true if I try to add bookmarks. I go to "Files -> Bookmarks", and all the bookmarks show up, but the buttons at the bottom to add, remove, or re-order the bookmarks are simply disabled.

What am I doing wrong?

share|improve this question

2 Answers 2

up vote 26 down vote accepted

Custom bookmarks

To add and remove custom bookmarks, refer to the documentation in Files ▸ Help ▸ Edit folder bookmarks:

Add a bookmark:

  1. Open the folder (or location) that you want to bookmark.

  2. Click the gear button in the toolbar and pick Bookmark this Location.

Delete a bookmark:

  1. Click on Files in the top bar and pick Bookmarks from the app menu.

  2. In the Bookmarks window, select the bookmark you wish to delete and click the - button.

The "gear button" is on the right side of Nautilus:

Bookmark this location - Nautilus - Ubuntu 13.10

It will be grayed out if the location you've opened is already bookmarked.

Places

The bookmarks seen under the "Places" heading are an exception:

Remove grayed out - Places - Nautilus - Ubuntu 13.10

They're not just bookmarks, but XDG user directories with a separate configuration backend, so the Nautilus developers deliberately chose to disable removing them.

The issue of working around this limitation is being discussed in this question.

share|improve this answer
    
I know that, but the bookmark system has issues. I have always used "Ctrl+D" to make bookmarks. Even using the actual button fails. –  Devyn Collier Johnson Oct 21 '13 at 21:03
    
This doesn't work - that option is also greyed out. Also doesn't help with being upble to remove existing bookmarks. –  Isaac Dontje Lindell Oct 21 '13 at 21:12
    
@IsaacDontjeLindell I've copied and pasted the documentation for removing bookmarks for you. When trying to add a bookmark, what folder did you open in step one? If it's already in the bookmarks (see Files ▸ Bookmarks) then it should be greyed out because you can't add it twice. –  ændrük Oct 21 '13 at 21:14
    
@ændrük Okay, that does allow me to create new bookmarks. Thanks. However, opening "Files -> Bookmarks" doesn't allow me to remove anything - all controls are greyed out (I mentioned this in my original question). I want to be able to remove things like Videos and Pictures, etc. –  Isaac Dontje Lindell Oct 21 '13 at 21:22
    
Ah! I understand. I was conflating the XDG user "places" with the bookmark system. Thank you, that makes much more sense. –  Isaac Dontje Lindell Oct 22 '13 at 17:23

I think I may have stumbled upon a way to add a bookmark for, say, the UbuntuOne folder.

First up, I connected to a SMB server, and I found that I was able to create a bookmark for this connection. This action created the Bookmarks entry in the left pane of Nautilus. Not sure if this is really necessary - it is just what I did.

Then I right-clicked on one of the folders in the Home folder (one I did not want to Bookmark say, Videos), and selected Copy to. This opened up the Select destination window.

I could then right-click on the folder I wanted to Bookmark and add it to the Bookmarks.

After that, I could rename, or remove, the bookmark if I wanted to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.