Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell XPS. I followed this tutorial to get NVidia working: https://wiki.ubuntu.com/HardwareSupport/Machines/Laptops/Dell/XPS/15z

I try to run the glxspheres and it fails with the message below:

optirun -vv -debug glxspheres
[   29.736785] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[   29.737854] [DEBUG]optirun version 3.2.1 starting...
[   29.737895] [DEBUG]Active configuration:
[   29.737906] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[   29.737916] [DEBUG] X display: ebug
[   29.737925] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-304:/usr/lib32/nvidia-304
[   29.737935] [DEBUG] Socket path: /var/run/bumblebee.socket
[   29.737944] [DEBUG] Accel/display bridge: auto
[   29.737953] [DEBUG] VGL Compression: proxy
[   29.737962] [DEBUG] VGLrun extra options: 
[   29.737972] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[   29.738223] [DEBUG]Using auto-detected bridge virtualgl
[   30.336829] [INFO]Response: No - error: [XORG] (EE) No devices detected.

[   30.336882] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[   30.336902] [DEBUG]Socket closed.
[   30.336945] [ERROR]Aborting because fallback start is disabled.
[   30.336964] [DEBUG]Killing all remaining processes.
share|improve this question
    
Have you solved your problem? –  Salem Apr 18 at 12:05

2 Answers 2

about bumblebee, I suggest you to reintall it at the rule write in https://wiki.ubuntu.com/Bumblebee.

share|improve this answer

I had the same problem with a Pavilion and manage to fix it by setting the BusID manually (as stated in https://wiki.ubuntu.com/Bumblebee).

Those are the steps you need to follow:

  1. Find the correct BusID using lspci | egrep 'VGA|3D' (example output):

    $ lspci | egrep 'VGA|3D'
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] (rev ff)
    

    As you can see, here the correct BusID is 01:00.0.

  2. Add the correct BusID to /etc/bumblebee/xorg.nvidia. You may find there already a line commented, just uncomment it and replace the BusID with the right one.

    $ cat /etc/bumblebee/xorg.nvidia
    ...
    BusID "PCI:01:00:0"
    ...
    

    NOTE: you will need to replace the last colon with a dot, or it will not work!

  3. Restart Bumblebee

    $ sudo service bumblebeed restart
    

Restarting Bumblebee should be enough. If you get the same error restart your machine and you are ready to go.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.