Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get Bumblebee working again after an upgrade to Saucy.

Running software with Optirun gives the following output:

optirun nvidia-settings
[   45.697126] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load /usr/lib/xorg/modules/libglamoregl.so: /usr/lib/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
[   45.697179] [ERROR]Aborting because fallback start is disabled.

Does anyone know how to fix this? Thanks! :)

share|improve this question

3 Answers 3

Only for ubuntu 13.10

sudo apt-get install nvidia-319-updates nvidia-settings-319-updates

Then you need to edit /etc/bumblebee/bumblebee.conf

KernelDriver=nvidia_319_updates
LibraryPath=/usr/lib/nvidia-319-updates:/usr/lib32/nvidia-319-updates
XorgModulePath=/usr/lib/nvidia-319-updates/xorg,/usr/lib/xorg/modules
Driver=nvidia

Restart bumblebee

sudo service bumblebeed restart

Now try :

optirun /usr/bin/<app>
share|improve this answer

Fix by purging and re-installing

I could not figure out the particular problem, but I was able to recover by purging all of the packages associated with bumblebee (I used the "Complete Removal" tag in Synaptic, which I believe is equivalent to the "purge" command in apt-get). I removed all packages matching bumblebee, nvidia, primus, and one called bbswitch-dkms. I re-installed bumblebee, bumblebee-nvidia, and mesa-tools. At that point, I could run optirun glxgears and primus glxgears.

I still find that other applications --- Cool VL Viewer and Imprudence --- which ran under optirun before my upgrade to Saucy now crash. Cool VL Viewer runs without optirun.

Also fix some library path problems

Cool VL Viewer and Imprudence required libraries i965.so and swrast.so, which were not on the paths that they searched.

I worked around the problem, without understanding the root of it, by entering two symbolic links:

/usr/lib64/dri -> /usr/lib/x86_64-linux-gnu/dri

/usr/lib32/dri -> /usr/lib/i386-linux-gnu/dri

I'm not sure whether to regard this as a Bumblebee problem, but the fact that Cool VL viewer worked without optirun, then failed with optirun, and the fact that the unfound libraries appear to relate to Intel graphics rather than Nvidia, suggest that the redirection of Intel calls is failing under some circumstances.

share|improve this answer
    
This doesn't fix for me. –  shantanu Oct 29 '13 at 20:44

I have exactly the same issue - seems to be related to this bug Fix provided there failed to solve this problem for me and it looks like we have to wait for a better release of it. Somebody have alredy mentioned there that the fix does not work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.