Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I simply don't use bluetooth. Since it can be a security risk and also drains the battery I would like to keep it deactivated. I quickly found the option to turn it off in the settings menu, but the problem is: it doesn't stay dead!

Everytime I pull my Nexus 4 out of standby mode bluetooth reappears in the top bar as if I never deactivated it.

How can I deactivate it so it stays deactivated or better yet how can I remove it from my phone entirely?
I tried sudo apt-get remove bluez bluetooth, but I am not allowed to edit this package.

share|improve this question

You can do so by disabling the upstart jobs for bluetooth and bluetooth-touch:

echo manual | sudo tee /etc/init/bluetooth.override
echo manual | sudo tee /etc/init/bluetooth-touch.override

The bluetooth job controls BlueZ, which is the daemon used to establish bluetooth connections, and the bluetooth-touch job controls the programs that enable the bluetooth device on bootup on the phone, based on the model of the device.

share|improve this answer
Sadly it doesn't work: tee: /etc/init/bluetooth.override: the filesystem is only readable – NotABluetoothUser Oct 21 '13 at 17:54
@NotABluetoothUser: You could try to run sudo mount / -o remount,rw before running the suggested commands. This should make your filesystem writeable. I am not sure if this the best way of achieving that, but in my case it works without problems. – Kai May 10 '14 at 12:22

I also do not use bluetooth and would like to disable it on startup. I tried to edit /etc/rc.local to include

rfkill block bluetooth

but I also encountered the fact that it was a readonly filesystem. Any ideas on how to permanently disable without changing /etc?

share|improve this answer
You need to open your editor with sudo rights. That would be gksudo gedit /etc/rc.local – MadMike Oct 24 '13 at 4:50

One way to make this possible is to make /etc/rc.local a symbolic link to /etc/writable/rc.local.
Bug #1261091 has been submitted to hopefully make this happen.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.