Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrade from 13.04 to 13.10 Brightness is not working. Please let me know how to fix this issue,

Machine configurations given below.

id: thinkpad
description: Notebook
product: 0301G8G ()
vendor: LENOVO
version: ThinkPad Edge
serial: LR236W5
architecture:   64 bits
share|improve this question
    
Worked perfectly for me!! Thanks!! Details: Machine: SAMSUNG Laptop (NP-R428) OS: Ubuntu 13.10 Change made in /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" sudo update-grub Restart. Worked like charm!!! Thanks!! –  Varun Varghese Apr 1 at 8:04

7 Answers 7

up vote 7 down vote accepted

Have you tried this:

  • Open terminal ( Ctrl+Alt+T ) and type:

    sudo cp /etc/default/grub /etc/default/grub.bak
    sudo gedit /etc/default/grub
    

    You will find this line in the new opened window: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  • Change it to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    
  • Save and close the window and type this in the terminal:

    sudo update-grub
    
  • Restart your system..

if above procedure doesn't work then repeat the same step but this time try to change the above mentioned line with:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

Note: The next line to the line mentioned above should be GRUB_CMDLINE_LINUX="" not GRUB_CMDLINE_LINUX="acpi_osi=Linux"

share|improve this answer
2  
The option one is working perfectly. Thanks. –  kds Oct 22 '13 at 4:28

I think you try to use ThinkPad's hotkey. You can try to adjust from Brightness and Lock setting in System Settings because maybe driver not working properly.

share|improve this answer
    
I have tried the both options that is not working. Note that I have setup the Gnome 3.8 as well. –  kds Oct 22 '13 at 4:21

I wrote a sample script based on bash dialog, in order to change my laptop brightness until they fix that in 13.10.

Here above is the link to the source on github: https://github.com/kjpopov/Ubuntu-Useful-Scripts/blob/master/choose_brightness

You can edit it to add more values, and also you can change the line 33 to make it work for your video adapter.

I am using Asus X55U laptop with Radeon HD 6290

Make sure you execute the script as super user (root) privileges.

Best Regards!

share|improve this answer
    
Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. –  RolandiXor Oct 31 '13 at 15:50

Try in terminal:

apt-get update
apt-get install brightness-controller
share|improve this answer
    
Could not be found –  Aaron Schif Nov 25 '13 at 1:55

1) Solution for brightness control for intel graphics in Ubuntu 13.10: One other thing to try would be to create the file /usr/share/X11/xorg.conf.d/20-intel.conf with the following content:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

2) Solution for brightness saving for intel graphics in Ubuntu 13.10: In terminal run command:

cat /sys/class/backlight/intel_backlight/max_brightness

My max brightness is 976, minimum 0. Run next command in terminal:

sudo gedit /etc/rc.local

Add following before the last line:

echo [value] > /sys/class/backlight/acpi_video0/brightness

where value is between 0 and max. Remember, never set 0 because 0 is black screen!

share|improve this answer

Same issue is persist in the 14.04 LTS. Once above stated steps are done this is working fine.

sudo cp /etc/default/grub /etc/default/grub.bak
sudo gedit /etc/default/grub

You will find this line in the new opened window: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save and close the window and type this in the terminal:

sudo update-grub
share|improve this answer

I have experienced the same problem with brightness values not persisting across machine reboots, after upgrading to 13.10.

Earlier I was using a python script to set the desired brightness, the script was set up as a startup application. I got it from somewhere in this forum. The script also no longer works since the gconf value does not seem to be valid any more with Gnome 3.8.

I have solved my problem by installing the xbacklight utility. I have added the following to my startup:

xbacklight -S 20

share|improve this answer
    
should be xbacklight -set 20 –  rubo77 Jul 2 at 8:26

protected by Community Apr 1 at 8:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.