Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Actually I practice C programs in vim editor.But font size in it is very small.Is there any option to increase the font size in vim editor?

share|improve this question
1  
You could try zooming in on your terminal with <Ctrl-Shift-+> –  bnjmn Oct 21 '13 at 15:35
    
are you using vim or gvim? –  Jesse Oct 21 '13 at 15:41
add comment

2 Answers

This may not be an ideal solution but it works for me.

Just zoom in on your terminal with Ctrl+Shift++.

Zoom out with Ctrl+-

share|improve this answer
add comment

According with http://vim.wikia.com/wiki/Change_font:

Console Vim uses whatever font your console/terminal is using. [...]

When running inside a terminal, Vim can, at most, change the colours (within the limits of the colours supported by the terminal: sometimes bold and unbold black and white, often 8 colours plus bold/unbold foreground only [or seen another way, 8 background and 16 foreground]; on X11 some terminals support up to 256 background and foreground colours; "changing colours" usually also includes the use of reverse-video), and, if the terminal supports them (not all terminals do, and even those which do may support it only with certain fonts), use bold, underline and/or italic.

That being said, if you want to change the font size in Vim editor, you have to change the font size of your terminal. To do this in gnome-terminal go to EditProfile Preferences:

Profile Preferences

Moreover, you can save these preferences in a new terminal profile and when you are start using Vim, use that profile.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.