Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Something I usually do after installing Ubuntu is reactivate the hibernation function. I find it quite useful to function for the more energy concious.

Typically, I'd complete the instructions in this tutorial for Ubuntu 12.04 and I'd be back in business. However, it does seem to work any more. Any suggestions?

http://www.howtogeek.com/113923/how-to-re-enable-hibernate-in-ubuntu-12.04/

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

[Enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
share|improve this question

marked as duplicate by LiveWireBT, Warren Hill, AgentCool, Aditya, Jorge Castro Oct 28 '13 at 14:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
This would be very helpful as suspend does not work on my machine at all. –  Joe Mills Oct 21 '13 at 14:44

3 Answers 3

I've found the solution, http://askubuntu.com/a/362499/193491. I've paraphrased the solution below:

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Paste the following and save the file.

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Restart the machine. The run sudo killall indicator-session-service once you've entered a new session, and then you'll have your hibernate functionality back.

share|improve this answer
    
I've restarted my machine a couple of times and the hibernate options has disappeared form the drop down menu. Running sudo killall indicator-session-service returns the option. Not what you'd call convenient. –  mjwittering Oct 21 '13 at 20:37
    
It means every time we turn on the computer we should run "sudo killall indicator-session-service"? isn't it a bad solution? –  user207048 Oct 24 '13 at 10:09
    
It's not a solution, it's still just a workaround until the bug that causes the menu to not be properly assembled is fixed. –  LiveWireBT Oct 28 '13 at 8:24

seems there is possibly no need for this in 13.10 [as was not the case in 12.04.12.10.13.04]

sudo pm-hibernate

works straight off on a clean install

installing qshutdown is also of great help as a gui to use hibernate on timer

share|improve this answer
    
This is an interesting work around. However it doesn't add hibernate back into the 'system' menu with: Log Out, Suspend and Shutdown. –  mjwittering Oct 21 '13 at 16:41
    
pm-hibernate worked in 13.04 too. –  Richard Borcsik Oct 25 '13 at 8:22

you can try the way explained in this link , it may work : http://ubuntuhandbook.org/index.php/2013/10/enable-hibernation-ubuntu-13-10/

share|improve this answer
    
Please avoid poor sources, this site recommends using sudo gedit. One must be pretty ignorant when running such a site and still doing this. askubuntu.com/questions/284306/… –  LiveWireBT Oct 28 '13 at 8:32
    
OK , I didn't know its not true to give the link of a page contains solution of problem . Thanks –  HOS Oct 28 '13 at 16:04
1  
No problem, were all here to learn new things. –  LiveWireBT Oct 28 '13 at 16:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.