Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to send a mail in Evolution, I get the following error:

Could not create message.

Because "Peer's certificate issuer has been marked as not trusted by the user. (-8172) - Cannot add MS SMIMEEncKeyPrefs attribute", you may need to select different mail options

share|improve this question
add comment

1 Answer

I solved this issue by marking the user certificate to use as "trusted peer" with certutil.

First install certutil if not already installed:

sudo apt-get install libnss3-tools

Then find the certificate nickname with

certutil -d sql:$HOME/.pki/nssdb -L

For me this nick is "Andreas Neustifter", it is different for you. Finally I marked this (my) certificate as trusted peer with

certutil -d sql:$HOME/.pki/nssdb -M -n "Andreas Neustifter" -t Pu,Pu,Pu

(Again, the nickname (given as option -n) is different for you...)

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.