Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to install Teamviewer, but I was getting a dependency error. I tried to install them, but with no luck.

I'm getting this error:

Unpacking teamviewer (from teamviewer_linux_x64.deb) ...
dpkg: dependency problems prevent configuration of teamviewer:
 teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not installed.
 teamviewer depends on lib32z1; however:
  Package lib32z1 is not installed.
 teamviewer depends on ia32-libs; however:
  Package ia32-libs is not installed.

dpkg: error processing teamviewer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer

I tried

sudo apt-get -f install

Getting

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

Package lib32asound2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lib32asound2' has no installation candidate
E: Package 'ia32-libs' has no installation candidate

I can't even get to the

sudo dpkg -i teamviewer_linux_x64.deb

If I force installation

sudo dpkg --force-depends -i teamviewer_linux_x64.deb

Although it's "Setting up Temviewer" it gives me this:

Enter image description here

How can I fix this problem?

share|improve this question
    
Install the "32-Bit / 64-Bit Multiarch" version. It worked on my system flawlessly. Do not install the 64bit only version. - teamviewer.com/en/download/linux.aspx –  Sepero Jun 6 at 14:25
    
Hey Sepero i Have Tried all the versions not even single one is working –  A.r. Naresh Aug 16 at 19:48

1 Answer 1

up vote 153 down vote accepted

The problem is that the teamviewer_linux_x64.deb has dependencies problems. Isn't recommended for distributions using multiarch (Ubuntu 12.04 and later). For said distributions the teamviewer_linux.deb package should be used.

This is noted in the help page of Teamviewer:

Notes to Multiarch:

On newer 64-bit DEB-systems with Multiarch-support (Debian 7) teamviewer_linux_x64.deb cannot be installed because the package ia32-libs is not available anymore on these systems. In this case you can use teamviewer_linux.deb instead.

So, how to install it?

First, download it:

wget http://www.teamviewer.com/download/teamviewer_linux.deb

Now you have 2 options. You can use gdebi (recommended) to solve the dependencies, or you can solve them yourself.

Gdebi method:

First, install gdebi:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install gdebi

In the same directory you downloade the .deb file just run:

sudo gdebi teamviewer_linux.deb

It will list the dependencies and install it with a y.

Manual method:

Here you need to do everything manual. First, query the package dependencies so you can install them first:

dpkg-deb -I teamviewer_linux.deb | grep Depends

It will return something like this:

Depends: libc6 (>= 2.4), libgcc1, libasound2, libfreetype6, zlib1g, libsm6, libxdamage1, libxext6, libxfixes3, libxrender1, libxtst6

Just installing such dependencies with :i386 should be enough:

sudo apt-get install libc6:i386 libgcc1:i386 libasound2:i386 libfreetype6:i386 zlib1g:i386 libsm6:i386 libxdamage1:i386 libxext6:i386 libxfixes3:i386 libxrender1:i386 libxtst6:i386 libxrandr2:i386

Then installing Teamviewer as normal:

sudo dpkg -i teamviewer_linux.deb

That should be all:

dpkg --no-act -i Downloads/teamviewer_linux.deb
dpkg: could not open log '/var/log/dpkg.log': Permission denied
Selecting previously unselected package teamviewer.
(Reading database ... 210950 files and directories currently installed.)
Unpacking teamviewer (from Downloads/teamviewer_linux.deb) ...
share|improve this answer
7  
I've tried Gdebi method, but it didn't helped. I'm getting: Dependency is not satisfiable: lib32asound2 –  Slava Fomin II Dec 16 '13 at 11:09
4  
@SlavaFominII install 32-bit instead –  ssgao Feb 10 at 22:23
    
what does :i386 mean? I'm on x64, should I use :i386? –  Alex Mar 22 at 5:34
    
@Alex yes. this answer is only applicable to 64-bit systems –  Braiam Mar 22 at 5:45
    
That's funny, doesn't i386 mean 32, whereas ia64 (or something) means 64-bit? –  Alex Mar 22 at 6:43

protected by Community Dec 5 '13 at 15:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.