Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu upgrade fails with following lines:

Calculating the changes
Calculating the changes
Could not calculate the upgrade 

An unresolvable problem occurred while calculating the upgrade. 

This can be caused by: 
Upgrading to a pre-release version of Ubuntu 
Running the current pre-release version of Ubuntu 
Unofficial software packages not provided by Ubuntu 

If none of this applies, then please report this bug using the 
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. 

Restoring original system state

Aborting
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
Building data structures... Done 

in the /var/log/dist-upgrade/apt.log

grep Broken /var/log/dist-upgrade/apt.log

Broken libwayland-client0:amd64 Conflicts on libwayland0 [ amd64 ] < 1.0.5-0ubuntu1 > ( libs ) (< 1.1.0)
Broken libunity9:amd64 Breaks on unity-common [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome ) (< 7.1.2)
Broken cups-filters:amd64 Conflicts on ghostscript-cups [ amd64 ] < 9.07~dfsg2-0ubuntu3.1 > ( text )
Broken libpam-systemd:amd64 Conflicts on libpam-xdg-support [ amd64 ] < 0.2-0ubuntu2 > ( admin )
Broken libharfbuzz0a:amd64 Breaks on libharfbuzz0 [ amd64 ] < 0.9.13-1 > ( libs )
Broken libharfbuzz0a:amd64 Breaks on libharfbuzz0 [ i386 ] < 0.9.13-1 > ( libs )
Broken libunity-scopes-json-def-desktop:amd64 Conflicts on libunity-common [ amd64 ] < 6.90.2daily13.04.05-0ubuntu1 > ( gnome ) (< 7.0.7)
Broken libunity-scopes-json-def-desktop:amd64 Conflicts on libunity-common [ i386 ] < none > ( none ) (< 7.0.7)
Broken libaccount-plugin-generic-oauth:amd64 Conflicts on account-plugin-generic-oauth [ amd64 ] < 0.10bzr13.03.26-0ubuntu1.1 > ( gnome ) (< 0.10bzr13.04.30)
Broken libaccount-plugin-generic-oauth:amd64 Breaks on account-plugin-generic-oauth [ amd64 ] < 0.10bzr13.03.26-0ubuntu1.1 > ( gnome ) (< 0.10bzr13.04.30)
Broken python3-aptdaemon.pkcompat:amd64 Breaks on libpackagekit-glib2-14 [ amd64 ] < 0.7.6-3ubuntu1 > ( libs ) (<= 0.7.6-4)
Broken libsnmp30:amd64 Breaks on libsnmp15 [ amd64 ] < 5.4.3~dfsg-2.7ubuntu1 > ( libs )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken unity-gtk2-module:amd64 Conflicts on appmenu-gtk [ amd64 ] < 12.10.3daily13.04.03-0ubuntu1 > ( libs )
Broken libqscintilla2-l10n:amd64 Breaks on libqscintilla2-translations [ amd64 ] < 2.7.1-0ubuntu1 > ( libs )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken unity-gtk3-module:amd64 Conflicts on appmenu-gtk3 [ amd64 ] < 12.10.3daily13.04.03-0ubuntu1 > ( libs )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken activity-log-manager:amd64 Conflicts on activity-log-manager-common [ amd64 ] < 0.9.4-0ubuntu6.2 > ( utils )
Broken libgtksourceview-3.0-0:amd64 Depends on libgtksourceview-3.0-common [ amd64 ] < 3.6.3-0ubuntu1 -> 3.8.2-0ubuntu1 > ( libs ) (< 3.7)
Broken libunity-core-6.0-5:amd64 Depends on unity-services [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 -> 7.1.2+13.10.20131014.1-0ubuntu1 > ( gnome ) (= 7.0.0daily13.06.19~13.04-0ubuntu1)
Broken libbamf3-1:amd64 Depends on bamfdaemon [ amd64 ] < 0.4.0daily13.06.19~13.04-0ubuntu1 -> 0.5.1+13.10.20131011-0ubuntu1 > ( libs ) (= 0.4.0daily13.06.19~13.04-0ubuntu1)
Broken geany-plugin-gdb:amd64 Depends on geany-plugins-common [ amd64 ] < 0.21.1.dfsg-4 -> 1.23+dfsg-3 > ( universe/devel ) (= 0.21.1.dfsg-4)
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken libxfixes3:amd64 Breaks on xserver-xorg-core [ amd64 ] < 2:1.13.4~git20130508+server-1.13-branch.10c42f57-0ubuntu0ricotz~raring -> 2:1.14.3-3ubuntu2 > ( x11 ) (< 2:1.14)
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati [ amd64 ] < 1:7.1.99+git20130730.6a278369-0ubuntu0sarvatt~raring -> 1:7.2.0-0ubuntu10 > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati [ amd64 ] < 1:7.1.99+git20130730.6a278369-0ubuntu0sarvatt~raring -> 1:7.2.0-0ubuntu10 > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )

Please help me to fix problem...

share|improve this question
    
Duplicate of askubuntu.com/questions/361716/… –  mmstick Oct 21 '13 at 8:32
    
A clean install via CD/DVD or USB stick would perhaps clear up the difficulty you are encountering. –  scouser73 Oct 21 '13 at 9:17

1 Answer 1

I had the same error. Removing the package called xserver-xorg-video-nouveau allows you to upgrade. You can always reinstall the package thereafter if you require it

share|improve this answer
    
thanks, this solved my problem. –  Fusion Apr 25 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.