Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While running an OS in VirtualBox on Ubuntu 10.10 amd64, I find the LCtrl(left-ctrl) key is not being properly detected. (The RCtrl(right-ctrl) is used by Virtual Box, but the LCtrl key should be available.) This makes programs like Emacs, that heavily rely on the control key, not work correctly. Searching the Internet, I found similar complaints that were fixed in by turning off Show position of pointer when the Ctrl key is pressed" in mouse preferences. Since this is already turned off on my system (actually in both host and client OS's), I don't think this is the problem.

My question: is this a bug, a feature or operator error?

share|improve this question
    
This appears to have been fixed for 13.04 (Raring): bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… –  Ryan Jan 8 '13 at 1:08

4 Answers 4

In Ubuntu 12.04, disabling the mouse pointer (System settings ► Mouse and Touchpad ► Show position of pointer when the Ctrl key is pressed) does the trick.

share|improve this answer
1  
He stated in the question that this option was already turned off. –  Ryan Jan 8 '13 at 1:07
    
Although, your answer didn't apply to the original poster, it did work on my Ubuntu, which is I think 12.04. –  Carl Morris Apr 9 at 14:49

As a workaround for Emacs in Virtual Box you can operate the control key functions by pressing

CapsLock+Control then release CapsLock while holding Control and press the corresponding funktion key (e.g. N).

To make use of the right shift key (however that key is also not fully operational in Virtual Box) you can define another Host key from the Virtual Box Manager settings in File -> Preferences -> Input.

share|improve this answer
    
Yes, this works for me. Thanks! I can now do things like C-x C-f in Emacs. –  Mike Goldberg Apr 22 '11 at 16:51
    
I was trying to do something similar for uni as a purely academic exercise (i.e. reading the Emacs manual and trying to EXACTLY replicate what was there). In the end I swapped to a different terminal with [ctrl]+[alt]+[f6] (unix.stackexchange.com/a/34519/10337) and ran the non-graphical, default version of Emacs with emacs -nw -q sample. This is a pretty specific use case, but it negates some of the issues you're describing. DISLAIMER - I'm pretty sure tty6 has some special purpose, but this is my sandbox Ubuntu VirtualBox instance and I don't care if I wreck it. –  Aaron Newton Aug 2 '12 at 12:53

I could get the control key to work by disabling "Highlight the pointer when you press Ctrl in the mouse preferences. This was on Fedora with Gnome 3, so it might not help you.

share|improve this answer

In my case the LCtrl(left-ctrl) was not functioning in the Guest OS because I have previously configured LCtrl key in the HOST OS to highlight the location of the mouse once pressed.

Once reverting in the HOST OS the LCtrl in the Guest OS is "back to business" as usual.
So Simple :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.