Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried several askubuntu threads but yet to no avail none have all met qualifications.

I installed allvideodownloader, and found a better version an earlier version; I downloaded from software-center, so there should not have been a related programs version problem and I got this error:

The following packages have unmet dependencies:
 allvideodownloader : Depends: allvideodownloader-bin (= 2.6.0-0ubuntu1)
 apache2.2-bin : Depends: libaprutil1-ldap but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I have tried the usual suspects, in synaptic, software-center and aptitude.

 apt-get autoremove --purge allvideodownloader
Package allvideodownloader is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

 apt-get remove --auto-remove allvideodownloader-bin
Package allvideodownloader is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

 apt-get remove --auto-remove allvideodownloader-bin
E Unable to locate package allvideoinstaller-bin

 sudo apt-get install allvideoinstaller-bin
E Unable to locate package allvideoinstaller-bin

This is what I believe to be so; allvideodownloader changed the versions on several packages at install and didn't change them back at uninstall. These packages are somehow not reverse compatible using usual means.

I am having a headache I am growing used to from staring at this problem and that wont help matters. I've tried manner of install , purge and repair of broken packages

Please advise me on a repair.

thx, DL

share|improve this question
    
what is the output of sudo apt-get install -f –  Ask Oct 21 '13 at 8:04
    
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded –  Diogenes Lantern Oct 21 '13 at 8:27
    
Try apt-get install -f allvideodownloader and comment what you get. –  arsaKasra Oct 21 '13 at 9:03
    
apt-get install -f allvideodownloader returned the same as above, unmet dependencies. –  Diogenes Lantern Oct 21 '13 at 11:26
add comment

1 Answer

up vote 1 down vote accepted

You just have to install dependencies, all of them at once, once you figure them all out. From that alone I see you need to sudo aptitude install allvideodownloader-bin libaprutil1-ldap allvideodownloder and if that errors it will show more dependencies and you just add those to your command and try again.

share|improve this answer
    
I posted above what that got me. See if you can make hide or tails of it? dl –  Diogenes Lantern Oct 21 '13 at 11:28
    
You have to install them all at the same time rather than one at a time as indicated above. –  mmstick Oct 21 '13 at 11:44
    
I'll try after a couple of hours sleep, thx, dl –  Diogenes Lantern Oct 21 '13 at 11:51
    
This worked. I had to do an install/uninstall at one time from the error generated by the above answer, thank you very much. –  Diogenes Lantern Oct 30 '13 at 16:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.