Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After the upgrade to 13.10 Saucy Salamander, the brightness controls stopped working. This worked fine from 12.04 throughout.

Does anyone have an idea how I can fix this? If not, can you point me at the right package to file a bug against?


Bug I filed so far:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1241745

Solutions I have tried:

/etc/default/grub

Changed this line to several options:

GRUB_CMDLINE_LINUX=""

  1. GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"
  2. GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
  3. GRUB_CMDLINE_LINUX=”acpi_osi="!Windows 2012"

sudo update-grub

None worked.

I also tried to use xbacklight, which didn't work either. xbacklight -get wouldn't return anything.

share|improve this question

5 Answers 5

the only way to change brightness is to use this command

sudo su

echo 150 > /sys/class/backlight/intel_backlight/brightness

all other solution does not work at the moment. this is not my work around. I don't remember where I found this but it works and hats off to the person who gave this workaround :)

Using Ubuntu 13.10 64Bit Wubi on Lenovo Z570

share|improve this answer
    
This does not work on my system. –  Ingo Oct 22 '13 at 16:29

If you're using intel video card do:

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following in the empty file then log out and log in again or reboot. That should fix your problem.

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"

EndSection
share|improve this answer
    
This does not work. Can you please propose this workaround in the bug report that I list? –  Ingo Dec 25 '13 at 10:36
    
@lngo If you run this command, what comes as your video card? for i in /sys/class/backlight/*; do echo $i; cat $i/brightness; cat $i/actual_brightness; cat $i/max_brightness; done –  Tatakai Wasumi Dec 25 '13 at 18:01
    
Never mind I see that you have an nvidia video card, this only works for intel cards –  Tatakai Wasumi Dec 25 '13 at 21:18
up vote 1 down vote accepted

As Timo Aaltonen (tjaalton) brought to my attention on IRC, this is bug related to the latest drivers nvidia-319-updates. Reverting back to 304 fixed my problems, although I call this rather a workaround than a fix, as I won't get many of the recent performance improvements of newer drivers.

share|improve this answer

Possibly the NVidia and Intel are separate bugs as seen on https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-319/+bug/1241745/comments/17. I filed a separate bug for Intel: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1255428.

For Intel, the solution given above does indeed work. An alternate is, you may just do in a terminal:

echo 150 | sudo tee /sys/class/backlight/intel_backlight/brightness

i.e. avoiding the sudo su or whatever and merging the two steps into one.

Note that this solution involves the problem of piping the output of a command to a file requiring su permission for writing to. See also http://stackoverflow.com/questions/82256/how-do-i-use-sudo-to-redirect-output-to-a-location-i-dont-have-permission-to-wr and http://stackoverflow.com/a/20234210/1503120.

I also wrote a simple PyQt4 GUI for this workaround. Please see the Intel LP bug for that.

share|improve this answer

As an interim workaround I use:

xrandr --output LVDS1 --brightness 0.8

To list output devices, execute "xrandr" without any flags.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.