Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been spending the weekend (and some time before that) trying to set up my Korean QHD270 and Benq G2222HDL monitors with Ubuntu 13.10.

With the nouveau drivers install both monitor function perfectly fine. After installing the nvidia drivers the Benq works but the QHD270 does not.

Now, after days of struggling I managed to get the QHD270 to work following a mixture of blogs, particularly; this one and learnitwithme. Now, unfortunatly my G2222HDL does not work. I fixed the QHD270 by supplying a custom EDID, my xorg.conf looks like so (excluding keyboard and mouse):

Section "ServerLayout"
    Identifier     "Layout0"
    Screen  "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Monitor"
     Identifier "Configured Monitor"
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    Option "CustomEDID" "DFP:/etc/X11/edid-shimian.bin"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
EndSection

Now, I tried defining a new Device,Monitor and Screen then in ServerLayout adding Screen "Second Screen" RightOf "Default Screen", but after doing so neither monitor worked.

Hoping to fix the issue using a GUI based tool I opened up NVIDIA X Server Settings, which shows my current layout as:

enter image description here

It seems that something is being output to the monitor, as suggested by my print screen:

enter image description here

Any help would be greatly appreciated.


Output of xrandr:

Screen 0: minimum 8 x 8, current 5120 x 1440, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440      60.0*+
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected 2560x1440+2560+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440      60.0*+
DP-1 disconnected (normal left inverted right x axis y axis)

And an extract from my log file (perhaps this is relevant?)

[     7.862] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 680 at PCI:2:0:0
[     7.862] (--) NVIDIA(0):     CRT-0
[     7.862] (--) NVIDIA(0):     ACB QHD270 (DFP-0) (boot, connected)
[     7.862] (--) NVIDIA(0):     DFP-1
[     7.862] (--) NVIDIA(0):     DFP-2
[     7.862] (--) NVIDIA(0):     DFP-3
[     7.862] (--) NVIDIA(0):     DFP-4
[     7.862] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[     7.862] (--) NVIDIA(0): ACB QHD270 (DFP-0): 330.0 MHz maximum pixel clock
[     7.862] (--) NVIDIA(0): ACB QHD270 (DFP-0): Internal Dual Link TMDS
[     7.862] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[     7.862] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[     7.862] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[     7.862] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[     7.862] (--) NVIDIA(0): DFP-3: 330.0 MHz maximum pixel clock
[     7.862] (--) NVIDIA(0): DFP-3: Internal Single Link TMDS
[     7.862] (--) NVIDIA(0): DFP-4: 960.0 MHz maximum pixel clock
[     7.862] (--) NVIDIA(0): DFP-4: Internal DisplayPort
share|improve this question
    
Have you tried the Ubuntu 'Displays' tool? Messing with the X.org configuration for this is a huge pain. I am successfully using two monitors with the nvidia drivers all set up with 'Displays'. Also, nvidia settings report the same monitor (ACB QHD270). You have likely configured something wrong. –  errikos Oct 23 '13 at 12:53
    
@errikos The Ubuntu screen display shows a similar situation to the nvidia one. There are two identical screens (the QHD270) –  HennyH Oct 24 '13 at 1:35
    
@HennyH what is the output of xrandr? Have you checked your log file in search of anything useful? –  fboaventura Oct 24 '13 at 2:50
    
@fboaventura I've added the output of xrandr, I didn't see anything useful in my log file, but I added the part I think lists the found displays. –  HennyH Oct 24 '13 at 3:12
    
@HennyH removing the configuration you made on your xorg.conf does both monitors get recognized by xorg? If yes, then what is the output of xrandr? –  fboaventura Oct 24 '13 at 3:30

1 Answer 1

You may try using the following xorg.conf. It configures two Screen and a ServerLayout section to manage them.

Section "Device"
    Identifier "nvidia0"
    Driver     "nvidia"
    Option     "CustomEDID" "DFP:/etc/X11/edid-shimian.bin"
    Option      "RenderAccel"              "true"
    Option      "UseEdidFreqs"             "true"
    Option      "MetaModes"     "2055x1440,1920x1080;1366x768,1366x768;1024x768,1024x768"
    Screen     0
    BusID      PCI:2:0:0
EndSection

Section "Device"
    Identifier "nvidia1"
    Driver     "nvidia"
    Option      "RenderAccel"              "true"
    Option      "UseEdidFreqs"             "true"
    Option      "MetaModes"     "2055x1440,1920x1080;1366x768,1366x768;1024x768,1024x768"
    Screen     1
    BusID      PCI:2:0:0
EndSection

Section "Monitor"
    Identifier "Monitor0"
    Option     "DPMS"
EndSection

Section "Monitor"
    Identifier "Monitor1"
    Option     "DPMS"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "nvidia0"
    Monitor    "Monitor0"
    DefaultDepth  24
    SubSection "Display"
        Depth      24
        Modes      "2055x1440" "1920x1080" "1366x768" "1024x768" 
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "nvidia1"
    Monitor    "Monitor1"
    DefaultDepth  24
    SubSection "Display"
        Depth      24
        Modes      "2055x1440" "1920x1080" "1366x768" "1024x768" 
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Screen     0 "Screen0" 0 0
    Screen     1 "Screen1" RightOf "Screen0"
    InputDevice "Generic Keyboard" "CoreKeyboard"
    InputDevice "Configured Mouse" "CorePointer"
    Option     "Xinerama"
EndSection

I may be missing something, so you will have to test this out. I used the confs from here as reference.

Another approach you may try is configuring your monitors manually, using xrandr. You will have to configure another Monitor section and even the second Device section without the EDID, nonetheless. But the command line would be:

$ xrandr --output DVI-I-1 --primary --mode 2560x1440 --output DVI-D-0 --mode 1920x1080 --right-of DVI-I-1

or even in multiple lines as:

$ xrandr --output DVI-I-1 --primary --mode 2560x1440
$ xrandr --output DVI-D-0 --mode 1920x1080 --right-of DVI-I-1

EDIT: Added MetaModes to Device section, and SubSection with modes to Screen section.

share|improve this answer
    
@fboventura I just tried using that config file, it had the same result as the one I tried. After rebooting the QHD270 did not work but the Benq did but it displays a 'Running in low graphics mode, configuration settings could not be determined' or something like that. Also with the xrandr it says xrandr: cannot find mode 1920x1080 –  HennyH Oct 24 '13 at 4:47
    
@HennyH just the xrandr throws something different? And, are the monitors plugged on the proper DVI ports? I assumed your Benq is plugged on the second port DVI-D-0. You may try switching them. –  fboaventura Oct 24 '13 at 4:58
    
@fboventura I checked using randr and the Benq (non-primary) is on DVI-D-0, because the primary is on DVI-I-1 which I suppose the one I'm currently using. –  HennyH Oct 24 '13 at 5:55
    
@HennyH changed some configurations. But, the suggestion from errikos above is valid. –  fboaventura Oct 24 '13 at 12:08
    
I just gave that new xorg.conf a go, had the same issuse as with the last version :(. I've looked into using the display settings to configure the monitors but I can't get it to work. –  HennyH Oct 24 '13 at 12:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.