Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from 13.04 to 13.10 and I can boot to the unity-greeter and login just fine, but after login I just get a black screen with a cursor. I have tried following

Also I have read

All of which were no further help then the two support articles about ATI drivers

So I switched back to the default drivers and went a little further into debugging, when I do ctrl+alt+F1 and login and try unity --debug > unity_start.log then ctrl+alt+F8 the screen stays black with a cursor and when I switch back ctrl+alt+F1 the contents of the log output are http://pastebin.com/rdQG4Hb0

However when I try sudo unity --debug > unity_start_root.log then ctrl+alt+F8, unity starts and the output of the log is http://pastebin.com/Yv4RD2j7

The fact that it starts as root tells be it is either a permissions issue of some required file or there is some setting that is specific to my user that is causing the SIGSEGV.

So to narrow this down I activated the guest account and tried to login and got the same black screens with only a mouse cursor, so this tells me that it is not a configuration issue, but a permissions issue, so how do I narrow down which file has the wrong permissions? Also is there anything further that may help debug this issue?

Ok after a few more hours of googling I found that if I add myself to the video group I can login and see the desktop, but there are lots of other permission related issues, so I am thinking something went wonky with PolicyKit during the upgrade, is there a way to reset PolicyKit settings for a user?

share|improve this question
add comment

2 Answers

I had the same problem.

I just fixed it. (kind of) My solution (so you can boot back to GUI) (don't know if it really was this or it was a lot of thing together):

after that I could reboot and login.

OPTIONAL: if you have login loop (type password and is accepted it will re-ask it): (make backup of file)
mv ~/.Xauthority ~/.Xauthority.old and retry to login.

any question, just ask.

cause: I think because old drivers (fglrx) are not supported, so replaced them with supported open-source drivers.

share|improve this answer
    
This did not fix the issue for me. I had to add my user to the video group to get Unity to stop Seg Faulting, and now I see alot of other permission issues –  Dj Gilcrease Oct 23 '13 at 18:09
add comment
up vote 0 down vote accepted

Ok I was able to fix this I had manually modified several files in /etc/pam.d so I created files in /usr/share/pam-configs that contained the custom modifications and ran sudo dpkg-reconfigure libpam-runtime

Now when I login all permissions work properly and I see no errors on startup

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.