Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Suddenly, the propriety Broadcom STA wireless driver ceased to work on my Inspiron 1525 Dell. All of a sudden, when I turned on the laptop the tooltip of the wireless indicator in the top panel shows networking disabled.

This also cause the wired network interface not to work, unless I manually dhclient it.

Indeed, lsmod doesn't show anything with bcm in it.

How can I further troubleshoot the issue?

share|improve this question
up vote 0 down vote accepted

Look at the file /var/lib/NetworkManager/NetworkManager.state. Very likely the attribute NetworkingEnabled or WirelessEnabled is set to false.

Make sure the two lines show


save the file and the restart the network-manager daemon with

sudo stop network-manager
sudo start network-manager

After this your network should come up again.

share|improve this answer
How could that happen? I didn't do anything with sudo at all. Moreover, after I suspended and got back from suspending it suddenly began to work. I really hate this kind of weird problems. – Elazar Leibovich Sep 5 '10 at 4:57
Yeah. sometimes that happens particularly when the computer crashes, or in conjunction with sleeping when it crashes from that state. If we would know exactly the details, we probably would have fixed it already. Otherwise, please use this workaround, and hopefully we will find the source and remove the problem in its entirety. – txwikinger Sep 5 '10 at 16:29
what you should do is, detect that the networking is not enabled, and add to the networking menu option to "Renew NetworkManager", in case it is off. Thanks. – Elazar Leibovich Sep 11 '10 at 18:56
it happens after I return from hibernate, and it for some reason fails to return from hibernate. I'll try to report a bug once details are clear... – Elazar Leibovich Sep 11 '10 at 18:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.