Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble with configuring my home server. I have an old lenovo x200 laptop that runs Xubuntu 13.10.

My problem is that after closing the lid the laptop is begin suspended despite changing all lid-related options in power management to "nothing". How to disable all actions (except turning the screen off) on lid close?

share|improve this question
2  
This is the actual bug report: bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/… –  AlexE Oct 21 '13 at 13:26

1 Answer 1

up vote 14 down vote accepted

I had the same problem, affecting the power button as well. This worked for me:

https://wiki.archlinux.org/index.php/xfce#xfce4-power-manager

/etc/systemd/logind.conf

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
share|improve this answer
    
How does the "Ask" setting translate into logind.conf's language? The man page mentions "ignore, poweroff, reboot, halt, kexec, suspend, hibernate, hybrid-sleep, lock" as options only. –  AlexE Oct 21 '13 at 12:10
    
Works like a charm. I noticied when you put "ignore" into logind.conf the xfce4-power-manager-settings works properly. –  user204783 Oct 22 '13 at 12:39
3  
It's enough to only use HandleLidSwitch=ignore –  Eyal Nov 2 '13 at 13:09

protected by Community Nov 27 '13 at 12:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.