Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running the Linux client for Steam on 13.04. Initially things seemed to work fine, but then Steam froze, and I had to force it to quit. I started it up again, but then it prompted me to update various 32-bit libraries. After doing this games now hang with a blank grey screen. I then re-installed my drivers after reading threads for similar issues, no luck though. Then I added

/usr/lib32
/usr/lib/i386-linux-gnu/mesa

to /etc/ld.so.conf.d/steam.conf.

That "fix" however created a new issue, "OpenGL GLX context is not using direct rendering, which may cause performance problems.", a known and common issue for 64-bit OS's. So I then ran

sudo apt-get install ia32-libs

in terminal. Still no change. I removed the lines I added to steam.conf, but no change. After reading several boards, I'm kinda at my wits end with this one.

share|improve this question
    
Which video card are you using? Can you edit your question with the output lspci | grep VGA? –  minerz029 Oct 20 '13 at 20:17
    
On a hunch, added /usr/lib32 only to steam.conf, and viola it worked. Can't believe I spent as much time on this as I have. Thanks :) –  bsmurfy Oct 20 '13 at 20:22
    
If that solved your problem, please post it as an answer below (not a comment) so that others can benefit. –  minerz029 Oct 20 '13 at 20:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.