Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have looked online (believe it or not) and I can't seem to find anything to help me with my issue. My clock just disappeared. Here's a screenshot!

disappeared clock

share|improve this question

closed as off-topic by Braiam, Alvin Row, bodhi.zazen, psusi, Sylvain Pineau Jun 20 '14 at 7:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Alvin Row, bodhi.zazen, psusi, Sylvain Pineau
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I had the same experience after upgrading from 13.04 to 13.10. It's one of the reasons why I'm not longer on 13.10. – user85164 Oct 20 '13 at 21:06
    
This is NOT a duplicate of the said question. This is not happening in Gnome, but in Unity. FWIW, restarting unity brought it back in my case. – Mladen Jablanović Jan 21 '14 at 11:47
    
I think that it is not a off-topic, since to me it as just a mistake, removing some packages.... – insign Nov 9 '15 at 13:33

Similar thing happened to me after upgrade to 13.10. I found that this bug describes it: https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1237361

I have it solved now, not sure if by installing system updates, by changing all related attributes in dconf-editor for node

com.canonical.indicator.datetime

or just by restarting unity (Alt+F2 -> "unity --replace") as commenter in above mentioned bug said it may help.

So maybe try to play a bit with settings and then trying restarting unity would not be a bad idea either.

share|improve this answer
12  
(Dunno how this got marked as a duplicate — Unity ≠ Gnome.) Replacing unity can cause the window manager to fail, so you get windows without controls that you can't move or close. I've had the most success with sudo killall unity-panel-service, which reinstates the clock immediately. – scruss Feb 5 '14 at 13:40
13  
for me, unity --replace was enough. thanks for that! – andreas-h Feb 21 '14 at 9:11
4  
@scruss, you don't need the sudo. You can just run killall unity-panel-service as described in the bug, No clock in menu bar and can't edit Clock settings. – Don Kirkby Jun 17 '14 at 17:54
    
thank you very much, it helped me .... :) – rashed azad Jan 3 '15 at 11:34

It's possible that it got uninstalled (most probably when you were trying to uninstall some other indicators). Try

sudo apt-get install indicator-datetime

Then recheck your Clock settings. That should hopefully be the problem

share|improve this answer
2  
Why the downvote? – asymptotically Oct 20 '13 at 21:06
1  
After running above comment I needed to also restart unity with unity --replace and my clock was back – walkeros Aug 3 '15 at 5:48

For me check the clock settings solved the problem.. actually "Show a clock in the menu bar" was already checked, I had to uncecheck it, close the settings, reopen the settings, checked this option back and finally it worked.

share|improve this answer
    
It would have been good if you said where the clock settings were – Anake Jan 7 '14 at 19:43
2  
@Anake: "System settings" -> "Time & Date" -> "Clock". – Antonello Jan 8 '14 at 7:38
    
that checkbox is grayed and I cant interact with it! – Aquarius Power Jan 16 at 17:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.