Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install on my nexus 10 Ubuntu. But every time I try to install

ubuntu@ubuntu:~$ sudo apt-get install phablet-tools android-tools-adb
android-tools-fastboot Reading package lists... Done Building
dependency tree        Reading state information... Done E: Unable to
locate package phablet-tools E: Unable to locate package
android-tools-adb E: Unable to locate package android-tools-fastboot

this appears. Could you please help me

Thanks

share|improve this question
    
The phablet-tools package is now deprecated. You should be using: sudo apt-get install ubuntu-device-flash. This also requires the Universe repository to be enabled. –  david6 Mar 2 at 1:01

3 Answers 3

I guess you haven't added the PPA which has the tools you're looking for. From Ubuntu wiki's instructions

Setup the Touch Developer Preview Tools PPA

The PPA has the tools and dependencies to support Precise, Quantal, and Raring. Add the Ubuntu Touch PPA by adding the following custom source list entry to your /etc/apt/sources.list file.

On your computer, press Ctrl+Alt+T to start a terminal.

sudo add-apt-repository ppa:phablet-team/tools

or if add-apt-repository is not available, append the following to your sources.list:

deb http://ppa.launchpad.net/phablet-team/tools/ubuntu [dist-codename] main

deb-src http://ppa.launchpad.net/phablet-team/tools/ubuntu [dist-codename] main

*Note: replace [dist-codename] with precise, quantal, raring or saucy.

Then do the following:

sudo apt-get update

sudo apt-get install phablet-tools android-tools-adb android-tools-fastboot

I hope this is helpful.

share|improve this answer

Which version of Ubuntu you use?

On your computer, open a terminal:

sudo add-apt-repository ppa:phablet-team/tools

https://wiki.ubuntu.com/Touch/Install

share|improve this answer

I faced the same issue on ubuntu 13.04 with nexus 4, I failed to install sudo apt-get install ubuntu-device-flash so I tried to root the device using Ubuntu Nexus 7 Desktop Installer and I followed the instruction here DualBootInstallation. i worked ;)

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.