Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I faced a strange function I installed ubuntu 13.10 and all the time the number pad on the right of my keyboard is typing number without pressing Num Lock and when I turn it on It does the job when Num Lock is normally off .

does anyone have this problem ? and any idea how to fix it ?

share|improve this question

marked as duplicate by Mitch, guntbert, Warren Hill, Kevin Bowen, belacq Oct 24 '13 at 21:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
can turn it on on boot and you can close it manually? –  user84277 Oct 20 '13 at 16:56
    
by default Num lock led is off but keypad is typing numbers but when I turn it on it does the other function –  Mohammad Oct 20 '13 at 16:58
    
if you want, we can turn it on with led at boot , sync led and keys. –  user84277 Oct 20 '13 at 17:00
    
yes I want to how ? –  Mohammad Oct 20 '13 at 17:02
    
i added it as answer. –  user84277 Oct 20 '13 at 17:05

2 Answers 2

up vote 4 down vote accepted

Install this application :

sudo apt-get install numlockx

Edit this file :

sudo vi /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Add Line at the end of file :

greeter-setup-script=/usr/bin/numlockx on

share|improve this answer
    
thanks problem solved . –  Mohammad Oct 24 '13 at 20:03
    
Thank you! I actually had the opposite issue and modified the command to turn off my numlock, since it was always getting in the way :)! (simply used off instead of on :)) –  Anton Petrov Nov 2 '13 at 14:41

Enabling numpad at boot will care of problem. With this link you can sync light and keys.

How to enable numpad at boot

share|improve this answer
    
there is nothing in this file : /etc/gdm/Init/Default that I add anything to it or edit it. –  Mohammad Oct 20 '13 at 17:30
    
there is another options too. try others. –  user84277 Oct 20 '13 at 19:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.