Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question seems to have a long history, but I was somehow unable to find a straightforward answer to it. I am using Ubuntu 10.10 with two or three keyboard layouts (US, RU, DE). When I first added additional layouts, there appeared a 3-letter code of the layout at the keyboard icon in the notification area, like this (this is an image from another post):

Keyboard layout indication

However, after some weeks of working with Ubuntu, I now have just the keyboard icon, no layout code:

enter image description here

I've no idea why it has disappeared. How can I get it back? :)


Just installed Ubuntu 11.04. In a fresh installation with two layouts, I again have an indicator without doing anything for it. Puzzled.

Screenshot of layout indicator

BTW, in the login screen the layout indicated to the right from the password field is unreadable with the "flag icons" suggested as a solution above. With the standard layout indicator, the letters are shown, which is better. So any suggestions as to why the standard layout indicator may disappear are welcome.

share|improve this question
add comment

2 Answers 2

Here is a slick solution: Language Flags Ubuntu Mono Dark http://gnome-look.org/content/show.php/Language+Flags+Ubuntu+Mono+Dark+11.04?content=140209

Also mono light, faenza. http://gnome-look.org/content/show.php/Language+Flags+for+Ubuntu+Mono+Light?content=134483

I think they look much nicer.

  1. Extract to ~/.icons/flags
  2. Run gconftool-2 --type bool --set /desktop/gnome/peripherals/keyboard/indicator/showFlags true
share|improve this answer
    
I like this solution (a bit misleading name 'Flag' though, since I want to have letters, and that's exactly what the linked collections provide). However, after I've done this, the keyboard icon is now replaced with a red backslashed circle (a symbol for 'no icon found'). I definitely have the svg files in ~/.icons/flags and /apps/desktop/gnome/peripherals/keyboard/indicator/showFlags is checked. If I uncheck it then after logging out and logging in the red 'no icon' icon is replaced back with the keyboard icon without the layout code. –  texnic Apr 22 '11 at 9:10
add comment

Having found no better answer, I just played around. Looks like the flag icons are only used by the Indicator Applet. This doesn't solve the original question (why the keyboard layout is not shown in the notification area) but the result looks well. I also like the sound control icon of the Indicator Applet more than the standard one from the notification area.

A nice side effect of using the Indicator Applet is that the typing break icon, which used to be the red backslashed circle (i.e. 'no icon found') with the standard keyboard icon in the notification area is now a green or red bar, depending on the status.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.