Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have asus n56vb with geforce 740 m and I just installed ubuntu 13.10, bumblebee with proprietary nvidia 319 driver, steam and dota 2. I can succesfully launch steam without optirun and with "optirun -b primus", but can't launch it with just optirun - here is console output.

As I understand the main problem is

primus: fatal: failed to load any of the libraries: /usr/lib/nvidia-319-updates/libGL.so.1:/usr/lib32/nvidia-nvidia-319-updates/libGL.so.1
/usr/lib/nvidia-319-updates/libGL.so.1: incorrect class ELF: ELFCLASS64
/usr/lib32/nvidia-nvidia-319-updates/libGL.so.1: unable to open shared object: No such file or catalogue

Then, if I open steam, I can launch dota 2, but I think it uses integrated video card (because I need to set all graphics options to minimal to get around ~40 fps). If I set "optirun -b primus %command%" or "optirun %command%" it doesn't launches at all.

So what should I do to make dota 2 execute on nvidia card? Here is my /etc/bumblebee/bumblebee.conf

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You have a typo in your bumblebee.conf file. In the line for the LibraryPath in the [driver-nvidia] section you have written,

LibraryPath=/usr/lib/nvidia-319-updates:/usr/lib32/nvidia-nvidia-319-updates

whereas by default the library would be present in,

LibraryPath=/usr/lib/nvidia-319-updates:/usr/lib32/nvidia-319-updates

Note the extra 'nvidia' in your line.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.