Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 2010.10 I installed VMware. Then I installed the 2011.04beta1 in VMware. Evrything worked fine, but after updating packages and rebooting I got the following popup:

It seems that you do not have the hardware required to run Unity. Please choose Ubuntu Classic at the login screen and you will be using the traditional environment.

It opens a session anyway. I have never tried Unity but I am pretty sure it opened a plain old Gnome session.

How can I trick out VMware to support Unity?

share|improve this question

3 Answers 3

up vote 6 down vote accepted

Dont think the vmware guest tools support Unity 3d yet - I havent had any luck with VMWare Player 3.x. See this also - How do I know if my video card can run Unity?

You could try installing unity-2d, or try using Virtualbox which does work with Unity 3d (most of the time).

See this link for install instructions - http://www.webupd8.org/2010/12/how-to-test-ubuntu-1104-with-unity-in.html

share|improve this answer

If using VirtualBox, you need to enable 3D acceleration in the VM settings (Display->Enable 3D acceleration).

share|improve this answer

If using VirtualBox, also don't forget set up Guest Addition.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.