Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently updated to 13.10 from 13.04. After rebooting, the system dropped into low graphics mode. I had previously configured a Wireless Broadband connection named:"EVDO Connection". How do I connect to this network from terminal?

[note] I tried using LiveCD and then the chroot command but then I was unable to make apt-get install any updates. It did not detect the internet connection.

Additional question, I read somewhere that

sudo apt-get update && sudo apt-get upgrade

will resolve the low graphics issue. Is that correct?

share|improve this question
    
It is preferred if you can post separate questions instead of combining your questions into one. That way, it helps the people answering your question and also others hunting for atleast one of your questions. Thanks! –  guntbert Oct 20 '13 at 20:11
add comment

2 Answers

You can use the following command for wireless devices:

iwconfig wlan0 essid NETWORK_NAME key WIRELESS_KEY

replacing the capital letters with the actual network and key

see the complete guide on linux.com

the commands you mention (update & upgrade) will update your system and additional software to the latest version, it may or not solve issues you are experiencing.

share|improve this answer
add comment

Ubuntu's NetworkManager service can be accessed via a command called nmcli. I'm not too sure if it's installed by default, but it seems it is, since it's part of the network-manager package.

To connect to a network, you need to know its NetworkManager ID. You can do so by using the following command:

nmcli connection

This should give you a list similar to this:

yjwong@yjwong-laptop:~/Documents/searchagram/build$ nmcli connection
NAME       UUID                                   TYPE              TIMESTAMP-REAL                    
Wong       6944f99a-21d2-4dd9-8ac4-a140e1024970   802-11-wireless   Fri 27 Sep 2013 04:26:04 PM
rpi        8084e8bd-c52c-4954-8721-0dac198604b7   802-11-wireless   Wed 01 May 2013 04:33:58 AM
AndroidAP  bb3e5a13-98e5-46eb-bfb4-c294f8757070   802-11-wireless   Mon 04 Nov 2013 05:01:11 PM
...

To bring up the "Wong" connection, simply execute:

nmcli connection up Wong

If your connection was named "EVDO Connection" you can execute:

nmcli connection up "EVDO Connection"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.