Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated Lubuntu 13.04 to 13.10 and now I have 2 network icons in the task bar what do I have to do so it displays just one icon?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

ok, found another way:

go to Start(in linux I believe is called Menu ?!)->Preferences->Desktop Session Settings uncheck Network from the list, click OK, then reboot how to

share|improve this answer

One way that survives a reboot is to go into Menu, Preferences, Default applications for LXSession. This is a new addition to Lubuntu 13.10 and apparently provides a GUI for adjusting certain settings. Unfortunately, I haven't come across documentation relating to it.

Anyway, I knew that I didn't have two network icons for the first day of running Lubuntu 13.10 but the two icons at startup came a day later.

I remembered tweaking a setting in Default applications for LXSession. Undoing that tweak, restores the single network icon in lxpanel on startup.

LXSession settings

In the Autostart tab, click on the box next to Disable autostarted applications and set it to config-only. The effect will be visible on reboot.

If you want certain applications of your own choice to autostart, you can use the GUI illustrated above: type or paste in the executable's command (and path). So something like lxterminal is enough but if I want a script of mine to run on startup, I'll enter /home/vasa1/bin/cpu-usage-alert.sh.

If you don't wish to use the GUI, you may edit ~/.config/lxsession/Lubuntu/autostart to look like, for example, this:

lxterminal
/home/vasa1/.dropbox-dist/dropbox
/home/vasa1/bin/cpu-usage-alert.sh

(It is recommended to press Enter after the last entry.)

share|improve this answer
    
ok, found another way: Start(in linux I believe is called Menu ?!)->Preferences->Desktop Session Settings uncheched Network from the list and rebooted, seems to work –  zmeul Oct 20 '13 at 6:57
    
@zmeul: then I suggest you to post your solution as an answer so that it will help others to get through their problem.. –  Saurav Kumar Oct 20 '13 at 7:01
    
I have a hard time making the reply pretty - I fail ; the board code is unknown and quite strange to me –  zmeul Oct 20 '13 at 7:07

Well it's simple

  • Right click on the taskbar and select Panel Settings

  • Go to Panel Applets tab

  • You'll get a System Tray Icon. Remove it. Be sure which one you are removing by moving it up/down by using the buttons on the right. You can later add it by clicking +Add button there.

  • Close the Panel Preferences window.

Thats it..:)

share|improve this answer
    
sorry, but this did not helped one bit –  zmeul Oct 20 '13 at 2:14
    
Have you actually tried this yourself in Lubuntu 13.10? Both nm-applets seem to be part of the same System Tray. I get rid of the second icon my finding out the other nm-applet process number and killing that one. –  user25656 Oct 20 '13 at 2:15
    
killing one nm-applet from the process list did work, but as soon as I reboot it's back to two icons –  zmeul Oct 20 '13 at 2:30
    
@zmeul, yes, that's why I didn't post the workaround as an answer :) –  user25656 Oct 20 '13 at 2:43

in "Default applications for LXSession" there is a section called "Network GUI", there is a drop-down list with "nm-applet" selected. click on that and set it to "no", hit "apply". log out and back in that's it. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.